summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-12 00:18:22 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-12 01:27:00 +0200
commitf727ec5bc8a6f97ae1083026e508b917235dfd2d (patch)
tree4dfd5f558517d276c42b4baaf6973c799bcd1e44
parent161094c8e2b46128544b85dae8e97d4fcb2818c0 (diff)
downloadguix-f727ec5bc8a6f97ae1083026e508b917235dfd2d.tar.gz
guix-f727ec5bc8a6f97ae1083026e508b917235dfd2d.tar.xz
gnu: perl: Do not retain references to Binutils and other build-time tools.
* gnu/packages/perl.scm (perl)[arguments]: Pass -Dlibpth and -Dplibpth to ./Configure.
-rw-r--r--gnu/packages/perl.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3d28455405..d1a0218158 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -72,7 +72,15 @@
"-Dinstallstyle=lib/perl5"
"-Duseshrplib"
(string-append "-Dlocincpth=" libc "/include")
- (string-append "-Dloclibpth=" libc "/lib"))))))
+ (string-append "-Dloclibpth=" libc "/lib")
+
+ ;; Force the library search path to contain only libc
+ ;; because it is recorded in Config.pm and
+ ;; Config_heavy.pl; we don't want to keep a reference
+ ;; to everything that's in $LIBRARY_PATH at build
+ ;; time (Binutils, bzip2, file, etc.)
+ (string-append "-Dlibpth=" libc "/lib")
+ (string-append "-Dplibpth=" libc "/lib"))))))
(add-before
'strip 'make-shared-objects-writable