summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-06-18 23:47:01 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-06-28 19:34:42 +0200
commit0d5c88737bcdde05511080359c7a5bdf963eec6a (patch)
tree105bad9d26a27cd6db1437c4647a92902fba4698
parent35ee95f481734146c16b09ade24ccc72addd9e70 (diff)
downloadguix-0d5c88737bcdde05511080359c7a5bdf963eec6a.tar.gz
guix-0d5c88737bcdde05511080359c7a5bdf963eec6a.tar.xz
gnu: Add ocaml-ppx-bitstring.
* gnu/packages/ocaml.scm (ocaml-ppx-bitstring): New variable.
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6e9170e929..59a883b400 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2016,6 +2016,22 @@ powerful.")
(propagated-inputs
`(("ocaml-ppx-tools-versioned" ,ocaml4.07-ppx-tools-versioned)))
(properties '()))))
+
+(define-public ocaml-ppx-bitstring
+ (package
+ (inherit ocaml-bitstring)
+ (name "ocaml-ppx-bitstring")
+ (arguments
+ `(#:package "ppx_bitstring"
+ ;; No tests
+ #:tests? #f))
+ (propagated-inputs (list ocaml-bitstring ocaml-ppxlib))
+ (native-inputs (list ocaml-ounit))
+ (properties `((upstream-name . "ppx_bitstring")))
+ (synopsis "PPX extension for bitstrings and bitstring matching")
+ (description
+ "This package provides a way to write bitstrings and matching over
+bitsrings in Erlang style as primitives to the language.")))
(define-public ocaml-result
(package