summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-06-28 15:07:32 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-06-28 15:07:32 +0200
commit22ec59e821924f2e74fec930273d21b03ff75115 (patch)
tree16f86735867a68b9a0d05f9deee4325460b1113c
parent9374af6b6f705a07a23c4451906aa2f6fac3e92a (diff)
downloadguix-22ec59e821924f2e74fec930273d21b03ff75115.tar.gz
guix-22ec59e821924f2e74fec930273d21b03ff75115.tar.xz
gnu: Add texlive-endfloat.
* gnu/packages/tex.scm (texlive-endfloat): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8b1416fd91..128a21cc7b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10889,3 +10889,23 @@ for copies for use in masked peer review.
The class is a development of the apa class (which is no longer
maintained).")
(license license:lppl1.3c+)))
+
+(define-public texlive-endfloat
+ (package
+ (inherit (simple-texlive-package
+ "texlive-endfloat"
+ (list "doc/latex/endfloat/"
+ "source/latex/endfloat/"
+ "tex/latex/endfloat/")
+ (base32
+ "1zslmc5g28z6adfyd8bdlbw03jawxmgafq0mgwy811hrbcppb2kg")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/endfloat")
+ (synopsis "Move floats to the end, leaving markers where they belong")
+ (description "Place all floats on pages by themselves at the end of
+the document, optionally leaving markers like “[Figure 3 about here]”
+in the text near to where the figure (or table) would normally have
+occurred. Float types figure and table are recognised by the package,
+unmodified. Since several packages define other types of float, it is
+possible to register these float types with endfloat.")
+ (license license:gpl2+)))