summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-06-18 23:28:59 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-06-28 19:34:22 +0200
commit99fcd03e500ae41bfdbc56866f1b1c8e81dfbf70 (patch)
tree595277f895fcbd38947a57d389377d2cab455e64
parentec90cdfdc39938778f8c0fd6ba1e9f2aba561992 (diff)
downloadguix-99fcd03e500ae41bfdbc56866f1b1c8e81dfbf70.tar.gz
guix-99fcd03e500ae41bfdbc56866f1b1c8e81dfbf70.tar.xz
gnu: Add ocaml-linenoise.
* gnu/packages/ocaml.scm (ocaml-linenoise): New variable.
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 4569c526ab..a8f328a266 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1939,6 +1939,30 @@ functions to the next and/or previous version.")
ocaml-migrate-parsetree")
(license license:expat))))
+(define-public ocaml-linenoise
+ (package
+ (name "ocaml-linenoise")
+ (version "1.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-community/ocaml-linenoise")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0s98695skz1wvrak0rdlh80w3cv6piic1dxqpn9rv1yymbklafg4"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; No tests
+ `(#:tests? #f))
+ (propagated-inputs (list ocaml-result ocaml-odoc))
+ (home-page "https://github.com/ocaml-community/ocaml-linenoise")
+ (synopsis "Lightweight readline alternative")
+ (description "This package is a line-reading library for OCaml that aims
+to replace readline.")
+ (license license:bsd-2)))
+
(define-public ocaml-bitstring
(package
(name "ocaml-bitstring")