summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2022-06-25 22:02:07 +0200
committerChristopher Baines <mail@cbaines.net>2022-06-28 22:43:58 +0100
commitaa565e7a10a3d8690a4296f8edf12abaa3c215c5 (patch)
treefea1c146e7e43a621f3e6d33d30e97d605daacc3
parent9f38e31548b5fb40a7067c590da59a4596dbce24 (diff)
downloadguix-aa565e7a10a3d8690a4296f8edf12abaa3c215c5.tar.gz
guix-aa565e7a10a3d8690a4296f8edf12abaa3c215c5.tar.xz
gnu: naev: Update to 0.9.3.
* gnu/packages/games.scm (naev): Update to 0.9.3. Fix lonely parens. [source]: Switch to git-fetch. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/games.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 910635c900..c6ed6eed00 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8033,14 +8033,17 @@ ncurses for text display.")
(define-public naev
(package
(name "naev")
- (version "0.9.2")
+ (version "0.9.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/naev/naev/releases/download/v"
- version "/naev-" version "-source.tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/naev/naev")
+ (commit (string-append "v" version))
+ (recursive? #t))) ; for game data
+ (file-name (git-file-name name version))
(sha256
- (base32 "1p6424n2rgrlb0h71gvww40vxs1h583d9im8bzgmv6dhgclbg0nl"))))
+ (base32 "0hvgxzvph9s5gdzlj5kjnz2d2j7bi8s11k7i6540837mnppah18j"))))
(build-system meson-build-system)
(arguments
;; XXX: Do not add debugging symbols, which cause the build to fail.
@@ -8079,8 +8082,7 @@ of lore accompanying everything from planets to equipment.")
license:public-domain
license:expat ;edtaa3func.c
license:bsd-2 ;distance_field.c
- license:bsd-3 ;perlin.c
- ))))
+ license:bsd-3)))) ;perlin.c
(define-public frotz-dumb-terminal
(package