summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2022-06-28 23:15:11 +0200
committerJonathan Brielmaier <jonathan.brielmaier@web.de>2022-06-28 23:56:10 +0200
commitd7449142f56cb0b34860f4ac90fc322aee32d177 (patch)
tree7e4b05d67f9b3f691e26ee0b168cb74e147b179d
parentaa565e7a10a3d8690a4296f8edf12abaa3c215c5 (diff)
downloadguix-d7449142f56cb0b34860f4ac90fc322aee32d177.tar.gz
guix-d7449142f56cb0b34860f4ac90fc322aee32d177.tar.xz
gnu: icedove: Update to 91.11.0 [security fixes].
Fixes CVE-2022-2226 and CVE-2022-34478. * gnu/packages/gnuzilla.scm (icedove): Update to 91.11.0.
-rw-r--r--gnu/packages/gnuzilla.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index aa76704167..7d8c531de3 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -977,11 +977,11 @@ standards of the IceCat project.")
(cpe-version . ,(first (string-split version #\-)))))))
;; Update this together with icecat!
-(define %icedove-build-id "20220531000000") ;must be of the form YYYYMMDDhhmmss
+(define %icedove-build-id "20220624000000") ;must be of the form YYYYMMDDhhmmss
(define-public icedove
(package
(name "icedove")
- (version "91.10.0")
+ (version "91.11.0")
(source icecat-source)
(properties
`((cpe-name . "thunderbird_esr")))
@@ -1260,7 +1260,7 @@ standards of the IceCat project.")
;; in the Thunderbird release tarball. We don't use the release
;; tarball because it duplicates the Icecat sources and only adds the
;; "comm" directory, which is provided by this repository.
- ,(let ((changeset "4a4b901410a9055d078d0cdd7c62b2b5d56ffbad"))
+ ,(let ((changeset "da48e7ecf800ec7761a3b6e0ca81e0c90adc30f7"))
(origin
(method hg-fetch)
(uri (hg-reference
@@ -1269,7 +1269,7 @@ standards of the IceCat project.")
(file-name (string-append "thunderbird-" version "-checkout"))
(sha256
(base32
- "0i2wpi08jfksqqc0j6q362nyk3zmlqd5ds2w7mm74infvrw6fzzq")))))
+ "0lg8z0zk05w8jah364lm7vkc95j1nkg93gf46byz0kd4nslg05nx")))))
("cargo" ,rust "cargo")
("clang" ,clang)
("llvm" ,llvm)