summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2022-06-28 15:09:26 +0200
committerLars-Dominik Braun <lars@6xq.net>2022-06-28 15:09:26 +0200
commitd8d6b7417f2ffcf12bfd639b55402199205d1177 (patch)
tree46aa4367c27462b42f43cf0041e6e734eaaa0792
parent5c608de9930cd0c49f567734d508cf84699b5e8b (diff)
downloadguix-d8d6b7417f2ffcf12bfd639b55402199205d1177.tar.gz
guix-d8d6b7417f2ffcf12bfd639b55402199205d1177.tar.xz
gnu: Add texlive-lineno.
* gnu/packages/tex.scm (texlive-lineno): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8bb451e507..e28ab35208 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10962,3 +10962,21 @@ provided by Philipp Lehmann’s etoolbox.")
(description "The package provides the functionality of the
threeparttable package to tables created using the longtable package.")
(license license:lppl1.3+)))
+
+(define-public texlive-lineno
+ (package
+ (inherit (simple-texlive-package
+ "texlive-lineno"
+ (list "doc/latex/lineno/"
+ "source/latex/lineno/"
+ "tex/latex/lineno/")
+ (base32
+ "1xf8ljgcj411yqmng89wc49rqfz19j95yqqpnb35dj3qc1chvm2a")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/lineno")
+ (synopsis "Line numbers on paragraphs")
+ (description "Adds line numbers to selected paragraphs with reference
+possible through the LaTeX @code{\\ref} and @code{\\pageref} cross reference
+mechanism. Line numbering may be extended to footnote lines, using the
+fnlineno package.")
+ (license license:lppl1.3a+)))