summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-28 16:26:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-28 16:26:51 +0100
commitc09f598d94af81f326fe1d4cf2ab344d4e720679 (patch)
tree36a1d0e792ceaf46c0d978d1b25bdcb133934108
parent38a404d567dbaed7c9bf3803e2580290d575f1dc (diff)
downloadguix-c09f598d94af81f326fe1d4cf2ab344d4e720679.tar.gz
guix-c09f598d94af81f326fe1d4cf2ab344d4e720679.tar.xz
gnu: python-matplotlib: Do not move the 'check' phase.
Running tests after install is now the default in PYTHON-BUILD-SYSTEM. * gnu/packages/python-xyz.scm (python-matplotlib)[arguments]: Replace 'check' phase, instead of deleting and adding new phase.
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a166554f98..fcc3972194 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4088,8 +4088,7 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(assoc-ref inputs "jquery-ui")
"-d" dir))
#t))
- (delete 'check)
- (add-after 'install 'check
+ (replace 'check
(lambda* (#:key outputs inputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
(invoke "python" "tests.py" "-v"