summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-06 23:42:47 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-07 00:18:36 +0200
commit33349e91f967883513a68ec824ab68e78aee528d (patch)
tree91cfa1f2a584dd4403769d839235142735e862b8 /Makefile.am
parent7f4da8ff6b382dce49954f272afc219b1ad4db20 (diff)
downloadguix-33349e91f967883513a68ec824ab68e78aee528d.tar.gz
guix-33349e91f967883513a68ec824ab68e78aee528d.tar.xz
build: Use 'guix pack -K' for the 'guix-binary*.tar.xz' targets.
* Makefile.am (guix-binary.%.tar.xz): Add -K flag for 'guix pack'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ee8fa1f14f..e035045468 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -504,10 +504,10 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
# The self-contained tarball. Add 'glibc-utf8-locales' along with glibc just
# so 'etc/profile' defines 'GUIX_LOCPATH' pointing to a valid set of locales.
guix-binary.%.tar.xz:
- $(AM_V_GEN)GUIX_PACKAGE_PATH= \
- tarball=`$(top_builddir)/pre-inst-env guix pack -C xz \
- -s "$*" --localstatedir guix glibc-utf8-locales \
- -e '(@@ (gnu packages commencement) glibc-final)'` ; \
+ $(AM_V_GEN)GUIX_PACKAGE_PATH= \
+ tarball=`$(top_builddir)/pre-inst-env guix pack -K -C xz \
+ -s "$*" --localstatedir guix glibc-utf8-locales \
+ -e '(@@ (gnu packages commencement) glibc-final)'` ; \
cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"