summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-09 11:44:21 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-09 11:44:21 +0100
commit6005bd0700544df27331c6aad9c7642dce9a91c8 (patch)
treea2e3fc28aa36c42dbd760235bd5a3d3dd76a9cac /Makefile.am
parent9f6f1aacf64371e0536fd52ea032dd164d08f436 (diff)
downloadguix-6005bd0700544df27331c6aad9c7642dce9a91c8.tar.gz
guix-6005bd0700544df27331c6aad9c7642dce9a91c8.tar.xz
build: Make sure the installed 'config.go' is newer than 'config.scm'.
Fixes <http://bugs.gnu.org/19317>. Reported by rekado <rekado@elephly.net>. * gnu-system.am (install-data-hook): Rename to... (set-bootstrap-executable-permissions): ... this. * Makefile.am (install-data-hook): New target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 25ff2224cc..bc0b95232e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -282,6 +282,13 @@ SUFFIXES = .go
guix_install_go_files = install-nobase_nodist_guilemoduleDATA
$(guix_install_go_files): install-nobase_dist_guilemoduleDATA
+# The above trick doesn't work for 'config.go' because both 'config.scm' and
+# 'config.go' are listed in $(nobase_nodist_guilemodule_DATA). Thus, give it
+# special treatment.
+install-data-hook: set-bootstrap-executable-permissions
+ touch "$(DESTDIR)$(guilemoduledir)/guix/config.go"
+
+
SUBDIRS = po/guix po/packages
BUILT_SOURCES =