summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-18 15:03:13 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-18 15:03:13 +0200
commit81f61c17c5a46e0ca720395da07d2c96d13e1bcf (patch)
tree2634cda156f2f9906bcb7a592999b37d5c07230d /Makefile.am
parentc4e52354c6716bf3630e96c3f142fe6fe6d2896a (diff)
downloadguix-81f61c17c5a46e0ca720395da07d2c96d13e1bcf.tar.gz
guix-81f61c17c5a46e0ca720395da07d2c96d13e1bcf.tar.xz
build: Add 'assert-final-inputs-self-contained' rule.
* build-aux/check-final-inputs-self-contained.scm: New file. * Makefile.am (EXTRA_DIST): Add it. (assert-final-inputs-self-contained): New target. (distcheck-hook): Depend on it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am51
1 files changed, 29 insertions, 22 deletions
diff --git a/Makefile.am b/Makefile.am
index c2345409a6..f454ae98e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -186,27 +186,28 @@ tests/guix-gc.log: \
# Public key used to sign substitutes from hydra.gnu.org.
dist_pkgdata_DATA = hydra.gnu.org.pub
-EXTRA_DIST = \
- HACKING \
- ROADMAP \
- TODO \
- .dir-locals.el \
- build-aux/hydra/gnu-system.scm \
- build-aux/hydra/demo-os.scm \
- build-aux/hydra/guix.scm \
- build-aux/check-available-binaries.scm \
- build-aux/download.scm \
- build-aux/list-packages.scm \
- build-aux/sync-descriptions.scm \
- srfi/srfi-37.scm.in \
- srfi/srfi-64.scm \
- srfi/srfi-64.upstream.scm \
- tests/test.drv \
- tests/signing-key.pub \
- tests/signing-key.sec \
- build-aux/config.rpath \
- bootstrap \
- release.nix \
+EXTRA_DIST = \
+ HACKING \
+ ROADMAP \
+ TODO \
+ .dir-locals.el \
+ build-aux/hydra/gnu-system.scm \
+ build-aux/hydra/demo-os.scm \
+ build-aux/hydra/guix.scm \
+ build-aux/check-available-binaries.scm \
+ build-aux/check-final-inputs-self-contained.scm \
+ build-aux/download.scm \
+ build-aux/list-packages.scm \
+ build-aux/sync-descriptions.scm \
+ srfi/srfi-37.scm.in \
+ srfi/srfi-64.scm \
+ srfi/srfi-64.upstream.scm \
+ tests/test.drv \
+ tests/signing-key.pub \
+ tests/signing-key.sec \
+ build-aux/config.rpath \
+ bootstrap \
+ release.nix \
$(TESTS)
if !BUILD_DAEMON_OFFLOAD
@@ -264,7 +265,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-daemon
dist-hook: sync-descriptions gen-ChangeLog assert-no-store-file-names
-distcheck-hook: assert-binaries-available
+distcheck-hook: assert-binaries-available assert-final-inputs-self-contained
sync-descriptions:
-$(top_builddir)/pre-inst-env $(GUILE) \
@@ -292,5 +293,11 @@ assert-binaries-available:
$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-available-binaries.scm"
+# Make sure the final inputs don't refer to bootstrap tools.
+assert-final-inputs-self-contained:
+ $(top_builddir)/pre-inst-env "$(GUILE)" \
+ "$(top_srcdir)/build-aux/check-final-inputs-self-contained.scm"
+
.PHONY: sync-descriptions gen-ChangeLog clean-go
.PHONY: assert-no-store-file-names assert-binaries-available
+.PHONY: assert-final-inputs-self-contained