summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-01-08 14:38:54 -0600
committerEric Bavier <bavier@member.fsf.org>2015-01-09 10:33:24 -0600
commit1ff2619bc114aface6b7b9d818f7208f9af677df (patch)
tree499f0d9f102b05bbb26e14a7a8e7b431231be509 /Makefile.am
parentc6cb82f5d5739fcc84281e5dc91076c37f1db89c (diff)
downloadguix-1ff2619bc114aface6b7b9d818f7208f9af677df.tar.gz
guix-1ff2619bc114aface6b7b9d818f7208f9af677df.tar.xz
import: Factorize utility functions.
* guix/import/pypi.scm (hash-table->alist, flatten, assoc-ref*, url-fetch, json-fetch): Pull procedures from here into... * guix/import/utils.scm: Here and... * guix/import/json.scm: Here. New file. * Makefile.am (MODULE)[HAVE_GUILE_JSON]: Add it. * guix/import/gnu.scm (file-sha256): Move from here to... * guix/hash.scm: Here. * tests/pypi.scm (pypi->guix-package): Update mock module reference.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bc0b95232e..c2bb1762ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -174,6 +174,7 @@ SCM_TESTS = \
if HAVE_GUILE_JSON
MODULES += \
+ guix/import/json.scm \
guix/import/pypi.scm \
guix/scripts/import/pypi.scm