summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-16 13:27:03 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-16 13:27:03 +0100
commit57b7e1a62d2269bfd9d37f88bae92c829222f8fc (patch)
tree5e6395e08025eb80de2040d77ac6febb558d2a72 /build-aux
parent72b703cdcaec260733a4e30800cef5eab3f071a6 (diff)
parentb01a0ba86e93012044f42c41ba5cbc7d7936c356 (diff)
downloadguix-57b7e1a62d2269bfd9d37f88bae92c829222f8fc.tar.gz
guix-57b7e1a62d2269bfd9d37f88bae92c829222f8fc.tar.xz
Merge branch 'core-updates'
Conflicts: gnu/packages/bootstrap.scm
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/check-available-binaries.scm53
-rw-r--r--build-aux/check-final-inputs-self-contained.scm5
-rw-r--r--build-aux/download.scm8
3 files changed, 33 insertions, 33 deletions
diff --git a/build-aux/check-available-binaries.scm b/build-aux/check-available-binaries.scm
index d5163a9503..7ac4352839 100644
--- a/build-aux/check-available-binaries.scm
+++ b/build-aux/check-available-binaries.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,31 +28,28 @@
(srfi srfi-1)
(srfi srfi-26))
-(define %supported-systems
- '("x86_64-linux" "i686-linux"))
+(with-store store
+ (let* ((native (append-map (lambda (system)
+ (map (cut package-derivation store <> system)
+ (list %bootstrap-tarballs emacs)))
+ %supported-systems))
+ (cross (map (cut package-cross-derivation store
+ %bootstrap-tarballs <>)
+ '("mips64el-linux-gnuabi64")))
+ (total (append native cross)))
+ (define (warn item system)
+ (format (current-error-port) "~a (~a) is not substitutable~%"
+ item system)
+ #f)
-(let* ((store (open-connection))
- (native (append-map (lambda (system)
- (map (cut package-derivation store <> system)
- (list %bootstrap-tarballs emacs)))
- %supported-systems))
- (cross (map (cut package-cross-derivation store
- %bootstrap-tarballs <>)
- '("mips64el-linux-gnuabi64")))
- (total (append native cross)))
- (define (warn proc)
- (lambda (drv)
- (or (proc drv)
- (begin
- (format (current-error-port) "~a is not substitutable~%"
- drv)
- #f))))
-
- (set-build-options store #:use-substitutes? #t)
- (let ((result (every (compose (warn (cut has-substitutes? store <>))
- derivation->output-path)
- total)))
- (when result
- (format (current-error-port) "~a packages found substitutable~%"
- (length total)))
- (exit result)))
+ (set-build-options store #:use-substitutes? #t)
+ (let* ((substitutable? (substitution-oracle store total))
+ (result (every (lambda (drv)
+ (let ((out (derivation->output-path drv)))
+ (or (substitutable? out)
+ (warn out (derivation-system drv)))))
+ total)))
+ (when result
+ (format (current-error-port) "~a packages found substitutable~%"
+ (length total)))
+ (exit result))))
diff --git a/build-aux/check-final-inputs-self-contained.scm b/build-aux/check-final-inputs-self-contained.scm
index ade4e98001..ca7e8030b4 100644
--- a/build-aux/check-final-inputs-self-contained.scm
+++ b/build-aux/check-final-inputs-self-contained.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,9 +29,6 @@
(srfi srfi-1)
(srfi srfi-26))
-(define %supported-systems
- '("x86_64-linux" "i686-linux"))
-
(define (final-inputs store system)
"Return the list of outputs directories of the final inputs for SYSTEM."
(append-map (match-lambda
diff --git a/build-aux/download.scm b/build-aux/download.scm
index 50123f59d2..a107a887dc 100644
--- a/build-aux/download.scm
+++ b/build-aux/download.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -45,7 +46,12 @@
(match (string-tokenize file (char-set-complement (char-set #\/)))
((_ ... system basename)
(string->uri (string-append %url-base "/" system
- "/20131110/" basename)))))
+ (match system
+ ("armhf-linux"
+ "/20150101/")
+ (_
+ "/20131110/"))
+ basename)))))
(match (command-line)
((_ file expected-hash)