summaryrefslogtreecommitdiff
path: root/build-aux
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-17 09:54:11 -0400
committerMark H Weaver <mhw@netris.org>2015-04-17 09:54:11 -0400
commit933204e5b1473a54367aef1f90de22424e9074ab (patch)
treed0ccfee2b903c5fac827bc4a52ec7de17bdc1e7b /build-aux
parent9128e323c0a23243c3f70b1716c68ad0b241f30d (diff)
parent5e25ebe2fa70297d094fe891b81c4970e45a906a (diff)
downloadguix-933204e5b1473a54367aef1f90de22424e9074ab.tar.gz
guix-933204e5b1473a54367aef1f90de22424e9074ab.tar.xz
Merge branch 'master' into core-updates
Conflicts: gnu-system.am gnu/packages/gstreamer.scm
Diffstat (limited to 'build-aux')
-rw-r--r--build-aux/hydra/gnu-system.scm26
-rw-r--r--build-aux/make-binary-tarball.scm50
2 files changed, 76 insertions, 0 deletions
diff --git a/build-aux/hydra/gnu-system.scm b/build-aux/hydra/gnu-system.scm
index cb2e209b21..01e2859f1a 100644
--- a/build-aux/hydra/gnu-system.scm
+++ b/build-aux/hydra/gnu-system.scm
@@ -54,6 +54,7 @@
(gnu packages multiprecision)
(gnu packages make-bootstrap)
(gnu packages commencement)
+ (gnu packages package-management)
(gnu system)
(gnu system vm)
(gnu system install)
@@ -161,6 +162,30 @@ system.")
(* 850 MiB))))))
'()))
+(define (tarball-jobs store system)
+ "Return Hydra jobs to build the self-contained Guix binary tarball."
+ (define (->alist drv)
+ `((derivation . ,(derivation-file-name drv))
+ (description . "Stand-alone binary Guix tarball")
+ (long-description . "This is a tarball containing binaries of Guix and
+all its dependencies, and ready to be installed on non-GuixSD distributions.")
+ (license . ,gpl3+)
+ (home-page . ,%guix-home-page-url)
+ (maintainers . ("bug-guix@gnu.org"))))
+
+ (define (->job name drv)
+ (let ((name (symbol-append name (string->symbol ".")
+ (string->symbol system))))
+ `(,name . ,(cut ->alist drv))))
+
+ ;; XXX: Add a job for the stable Guix?
+ (list (->job 'binary-tarball
+ (run-with-store store
+ (mbegin %store-monad
+ (set-guile-for-build (default-guile))
+ (self-contained-tarball))
+ #:system system))))
+
(define job-name
;; Return the name of a package's job.
(compose string->symbol package-full-name))
@@ -234,6 +259,7 @@ valid."
(cons job result)
result)))
(append (qemu-jobs store system)
+ (tarball-jobs store system)
(cross-jobs system))))
((core)
;; Build core packages only.
diff --git a/build-aux/make-binary-tarball.scm b/build-aux/make-binary-tarball.scm
new file mode 100644
index 0000000000..0b5dbaf1de
--- /dev/null
+++ b/build-aux/make-binary-tarball.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+;;;
+;;; Build a self-contained tarball containing binaries for Guix and its
+;;; dependencies.
+;;;
+
+(use-modules (guix)
+ (guix ui)
+ (gnu system install)
+ (ice-9 match))
+
+(define show-what-to-build*
+ (store-lift show-what-to-build))
+
+(define copy-file*
+ (lift2 copy-file %store-monad))
+
+(define rename-file*
+ (lift2 rename-file %store-monad))
+
+(match (command-line)
+ ((_ system file)
+ (with-store store
+ (run-with-store store
+ (mlet %store-monad ((tarball (self-contained-tarball)))
+ (mbegin %store-monad
+ (show-what-to-build* (list tarball))
+ (built-derivations (list tarball))
+ (copy-file* (derivation->output-path tarball)
+ (string-append file ".part"))
+ (rename-file* (string-append file ".part") file)))
+ #:system system))))