summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-19 23:09:36 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-19 23:09:36 +0100
commitc217708f7bf6a0fc6a77864134ac68091dc24327 (patch)
treecceeee6b4f59e3b089f6fff2dd91132ca59eae9f /configure.ac
parent2ffa297ab84c74d0d496076d5ea0e9833a960ad1 (diff)
downloadguix-c217708f7bf6a0fc6a77864134ac68091dc24327.tar.gz
guix-c217708f7bf6a0fc6a77864134ac68091dc24327.tar.xz
build: Use "nix-instantiate" as the default name for that program.
* configure.ac: Have `NIX_INSTANTIATE' default to `nix-instantiate'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c71016782..cbca81a3cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,12 @@ if test "x$guix_build_daemon$NIX_INSTANTIATE$NIX_HASH" = "xno"; then
AC_MSG_ERROR([Nix programs not found; please install Nix or use `--with-nix-prefix'.])
fi
+if test "x$NIX_INSTANTIATE" = "x"; then
+ # This program is an optional dependency, so we just want it to be
+ # taken from $PATH if it's not available right now.
+ NIX_INSTANTIATE="nix-instantiate"
+fi
+
AC_ARG_WITH([nixpkgs],
[AS_HELP_STRING([--with-nixpkgs=DIR], [search for Nixpkgs in DIR])],
[case "$withval" in