summaryrefslogtreecommitdiff
path: root/daemon.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-06 00:03:26 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-06 00:07:08 +0100
commit69cfce50dbb2000c5f5d98f0f364fe324004bf99 (patch)
treeceb925ad7fa3f30b88c6074a071a229a31f769eb /daemon.am
parentb980f0f9fd6f926f2a1130f77bd3cdb70e741429 (diff)
downloadguix-69cfce50dbb2000c5f5d98f0f364fe324004bf99.tar.gz
guix-69cfce50dbb2000c5f5d98f0f364fe324004bf99.tar.xz
build: Run all the tests against the just-built daemon.
* test-env.in: New file. * configure.ac: Add it to `AC_CONFIG_FILES' and `commands-exec'. * config-daemon.ac: Set and substitute `GUIX_TEST_ROOT'. * Makefile.am (SCM_LOG_COMPILER, SH_LOG_COMPILER): Use it in lieu of `pre-inst-env'. * daemon.am (test_root): Remove (AM_TESTS_ENVIRONMENT): Remove `TEST_ROOT'. (clean-local): Use $(GUIX_TEST_ROOT); make files writable before removing them.guix_test_root * tests/guix-daemon.sh: Remove `NIX_' variable settings; don't launch `guix-daemon'.
Diffstat (limited to 'daemon.am')
-rw-r--r--daemon.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/daemon.am b/daemon.am
index f5d58ea275..8c2c22dd88 100644
--- a/daemon.am
+++ b/daemon.am
@@ -155,15 +155,12 @@ EXTRA_DIST += \
nix/AUTHORS \
nix/COPYING
-# Temporary directory used to store the daemon's data.
-test_root = $(abs_top_builddir)/test-tmp
-
AM_TESTS_ENVIRONMENT += \
- top_builddir="$(abs_top_builddir)" \
- TEST_ROOT="$(test_root)"
+ top_builddir="$(abs_top_builddir)"
TESTS += \
tests/guix-daemon.sh
clean-local:
- -rm -rf "$(test_root)"
+ -find "$(GUIX_TEST_ROOT)" | xargs chmod +w
+ -rm -rf "$(GUIX_TEST_ROOT)"