summaryrefslogtreecommitdiff
path: root/distro/packages/libsigsegv.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-18 01:06:24 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-18 01:07:31 +0100
commit1ffa7090b99dfd2f54fa883929c5e78d7852657a (patch)
tree1c8bd191e31212e172b3e9158408cccd571a5020 /distro/packages/libsigsegv.scm
parent08ba7ff318720d926215de83daed0da628908ca3 (diff)
downloadguix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.gz
guix-1ffa7090b99dfd2f54fa883929c5e78d7852657a.tar.xz
distro: Change the module name space to (gnu ...).
* distro: Rename to... * gnu: ... this. Update module names accordingly. * Makefile.am: Adjust accordingly. * po/POTFILES.in: Likewise. * distro.scm: Search for files under /gnu/packages instead of /distro/packages. * gnu/packages/base.scm (ld-wrapper-boot3): Likewise.
Diffstat (limited to 'distro/packages/libsigsegv.scm')
-rw-r--r--distro/packages/libsigsegv.scm47
1 files changed, 0 insertions, 47 deletions
diff --git a/distro/packages/libsigsegv.scm b/distro/packages/libsigsegv.scm
deleted file mode 100644
index a21e2064c7..0000000000
--- a/distro/packages/libsigsegv.scm
+++ /dev/null
@@ -1,47 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages libsigsegv)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix utils)
- #:use-module (guix build-system gnu))
-
-(define-public libsigsegv
- (package
- (name "libsigsegv")
- (version "2.10")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://gnu/libsigsegv/libsigsegv-"
- version ".tar.gz"))
- (sha256
- (base32 "16hrs8k3nmc7a8jam5j1fpspd6sdpkamskvsdpcw6m29vnis8q44"))))
- (build-system gnu-build-system)
- (home-page "http://www.gnu.org/software/libsigsegv/")
- (synopsis "GNU libsigsegv, a library to handle page faults in user mode")
- (description
-"GNU libsigsegv is a library for handling page faults in user mode. A page
-fault occurs when a program tries to access to a region of memory that is
-currently not available. Catching and handling a page fault is a useful
-technique for implementing pageable virtual memory, memory-mapped access to
-persistent databases, generational garbage collectors, stack overflow
-handlers, distributed shared memory, and more.")
- (license gpl2+)))