summaryrefslogtreecommitdiff
path: root/doc/guix.texi
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-01-08 14:51:13 -0600
committerEric Bavier <bavier@member.fsf.org>2015-01-09 10:38:26 -0600
commitd45dc6da5c802024f31dba95919c06205c5e31e4 (patch)
treecea230023a562edb0fc474eb47cc92692926ad25 /doc/guix.texi
parent694b317c2dfac5f8b284a5831e20d89cc112bd6b (diff)
downloadguix-d45dc6da5c802024f31dba95919c06205c5e31e4.tar.gz
guix-d45dc6da5c802024f31dba95919c06205c5e31e4.tar.xz
import: Add CPAN importer.
* guix/import/cpan.scm, guix/scripts/import/cpan.scm, tests/cpan.scm: New files. * Makefile.am (MODULE)[HAVE_GUILE_JSON]: Add them. * guix/scripts/import.scm (importers): Add cpan. * doc/guix.texi (Requirements): Mention `guix import cpan` as a user of guile-json. (Invoking guix import): Document new `guix import cpan` command.
Diffstat (limited to 'doc/guix.texi')
-rw-r--r--doc/guix.texi24
1 files changed, 20 insertions, 4 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 12a1808137..8341a707d0 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -258,10 +258,10 @@ interest primarily for developers and not for casual users.
@item
Installing @uref{http://gnutls.org/, GnuTLS-Guile} will
allow you to access @code{https} URLs with the @command{guix download}
-command (@pxref{Invoking guix download}) and the @command{guix import
-pypi} command. This is primarily of interest to developers.
-@xref{Guile Preparations, how to install the GnuTLS bindings for Guile,,
-gnutls-guile, GnuTLS-Guile}.
+command (@pxref{Invoking guix download}), the @command{guix import pypi}
+command, and the @command{guix import cpan} command. This is primarily
+of interest to developers. @xref{Guile Preparations, how to install the
+GnuTLS bindings for Guile,, gnutls-guile, GnuTLS-Guile}.
@end itemize
Unless @code{--disable-daemon} was passed to @command{configure}, the
@@ -2957,6 +2957,22 @@ package:
guix import pypi itsdangerous
@end example
+@item cpan
+@cindex CPAN
+Import meta-data from @uref{https://www.metacpan.org/, MetaCPAN}.
+Information is taken from the JSON-formatted meta-data provided through
+@uref{https://api.metacpan.org/, MetaCPAN's API} and includes most
+relevant information. License information should be checked closely.
+Package dependencies are included but may in some cases needlessly
+include core Perl modules.
+
+The command command below imports meta-data for the @code{Acme::Boolean}
+Perl module:
+
+@example
+guix import cpan Acme::Boolean
+@end example
+
@item nix
Import meta-data from a local copy of the source of the
@uref{http://nixos.org/nixpkgs/, Nixpkgs distribution}@footnote{This