summaryrefslogtreecommitdiff
path: root/emacs.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-27 17:26:22 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-27 17:27:21 +0200
commit596fcbf768828bb88c28107c6312e63f8329f430 (patch)
tree88cca45dac2109ede79823d08a2260a86bac9b5f /emacs.am
parent6c4a2884b68b9c3344ef0c9f74e0399c6eb1608c (diff)
downloadguix-596fcbf768828bb88c28107c6312e63f8329f430.tar.gz
guix-596fcbf768828bb88c28107c6312e63f8329f430.tar.xz
build: Don't generate Emacs autoloads when Emacs is unavailable.
Reported by Andreas Enge. * configure.ac: Define 'HAVE_EMACS' Automake conditional. * emacs.am ($(AUTOLOADS)): Wrap in 'if HAVE_EMACS'.
Diffstat (limited to 'emacs.am')
-rw-r--r--emacs.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/emacs.am b/emacs.am
index 86ae3a2c9f..6ef9d1c326 100644
--- a/emacs.am
+++ b/emacs.am
@@ -34,6 +34,8 @@ dist_lisp_DATA = \
nodist_lisp_DATA = \
emacs/guix-init.el
+if HAVE_EMACS
+
$(AUTOLOADS): $(ELFILES)
$(EMACS) --batch --eval \
"(let ((backup-inhibited t) \
@@ -41,3 +43,5 @@ $(AUTOLOADS): $(ELFILES)
(expand-file-name \"$(AUTOLOADS)\" \"$(srcdir)\"))) \
(update-directory-autoloads \
(expand-file-name \"emacs\" \"$(srcdir)\")))"
+
+endif HAVE_EMACS