summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-01 17:42:07 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2018-02-12 16:25:35 +0100
commit0093e26f911cc9a055615d599b2e44b4d3a6cf6a (patch)
treeceffd1a8efcff2fc9beac685506210b0b7d0a0cb /gnu/packages/kde-frameworks.scm
parent7f1d9bef503e546eb3572e7930793dcbe0d2407e (diff)
downloadguix-0093e26f911cc9a055615d599b2e44b4d3a6cf6a.tar.gz
guix-0093e26f911cc9a055615d599b2e44b4d3a6cf6a.tar.xz
gnu: Add kirigami.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index ef2a7cb07c..5f209a2c20 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -766,6 +766,57 @@ but also for getting notified upon idle time events, such as custom timeouts,
or user activity.")
(license (list license:gpl2+ license:lgpl2.1+))))
+(define-public kirigami
+ ;; Kirigami is listed as tier 1 framework, but optionally includes
+ ;; plasma-framework which is tier 3.
+ (package
+ (name "kirigami")
+ (version "5.39.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ "kirigami2-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0spgylk4yjy74rs5d5b28qv72qz5ra9j3wfmk6vx2b6cvf1fw517"))))
+ (properties `((upstream-name . "kirigami2")))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ;; TODO: Find a way to activate this optional include without
+ ;; introducing a recursive dependency.
+ ;;("plasma-frameworks" ,plasma-framework) ;; Tier 3!
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("qtsvg" ,qtsvg)
+ ;; Run-time dependency
+ ("qtgraphicaleffects" ,qtgraphicaleffects)))
+ (arguments
+ `(#:tests? #f ;; FIXME: Test suite is broken,
+ ;; see https://bugs.kde.org/show_bug.cgi?id=386456
+ ;; Note for when enabling the tests: The test-suite is meant to be run
+ ;; without prior installation, see
+ ;; https://cgit.kde.org/kirigami.git/commit/?id=24ad2c9
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; make Qt render "offscreen", required for tests
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "QtQuick components for mobile user interfaces")
+ (description "Kirigami is a set of high level QtQuick components looking
+and feeling well on both mobile and desktop devices. They ease the creation
+of applications that follow the Kirigami Human Interface Guidelines.")
+ (license license:lgpl2.1+)))
+
(define-public kitemmodels
(package
(name "kitemmodels")