summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-05-24 19:24:48 -0400
committerLeo Famulari <leo@famulari.name>2022-06-29 08:49:42 -0400
commit5bf97d28918223371cc97c3f23757ff769b1212d (patch)
tree7c4dd944dc2c569e09c7c8b50d89a8e7d2044ce8 /gnu/packages/linux.scm
parentc62f6268e7827ce58dead8f5df117ef85ce57762 (diff)
downloadguix-5bf97d28918223371cc97c3f23757ff769b1212d.tar.gz
guix-5bf97d28918223371cc97c3f23757ff769b1212d.tar.xz
gnu: Add linux-libre 5.18.
* gnu/packages/linux.scm (linux-libre-5.18-version, linux-libre-5.18-gnu-revision, deblob-scripts-5.18, linux-libre-5.18-pristine-source, linux-libre-5.18-source, linux-libre-headers-5.18, linux-libre-5.18): New variables. * gnu/packages/aux-files/linux-libre/5.18-arm.conf, gnu/packages/aux-files/linux-libre/5.18-arm64.conf, gnu/packages/aux-files/linux-libre/5.18-i686.conf, gnu/packages/aux-files/linux-libre/5.18-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 80fe24817d..ec10060952 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -352,6 +352,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+(define-public linux-libre-5.18-version "5.18.7")
+(define-public linux-libre-5.18-gnu-revision "gnu")
+(define deblob-scripts-5.18
+ (linux-libre-deblob-scripts
+ linux-libre-5.18-version
+ linux-libre-5.18-gnu-revision
+ (base32 "09aikdhij4d89wqd8mmkdr0nrfwqz6dx3n74qm6wx815rfngd2dz")
+ (base32 "0vjpn8iw9yg39sr6jfhzyvivf159h9zfgnjamwa283zfll0h0a53")))
+(define-public linux-libre-5.18-pristine-source
+ (let ((version linux-libre-5.18-version)
+ (hash (base32 "0nsj44p1wn7ysckhv4a99ncj0a9xxhvi54v63w1047sspxjd18m1")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.18)))
+
(define-public linux-libre-5.17-version "5.17.15")
(define-public linux-libre-5.17-gnu-revision "gnu")
(define deblob-scripts-5.17
@@ -488,6 +503,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.18-source
+ (source-with-patches linux-libre-5.18-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.17-source
(source-with-patches linux-libre-5.17-pristine-source
(list %boot-logo-patch
@@ -602,6 +622,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.18
+ (make-linux-libre-headers* linux-libre-5.18-version
+ linux-libre-5.18-gnu-revision
+ linux-libre-5.18-source))
+
(define-public linux-libre-headers-5.17
(make-linux-libre-headers* linux-libre-5.17-version
linux-libre-5.17-gnu-revision
@@ -923,6 +948,13 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-5.18
+ (make-linux-libre* linux-libre-5.18-version
+ linux-libre-5.18-gnu-revision
+ linux-libre-5.18-source
+ '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-5.17
(make-linux-libre* linux-libre-5.17-version
linux-libre-5.17-gnu-revision