summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-07-27 15:13:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-07-27 15:30:38 +0200
commited2dfe3955f0144bc858c66fdb751f51e9bd84fe (patch)
tree5e8fdebcf590d21cc62db8400426e93dd44405dc /gnu/packages/python.scm
parent269f100330cf92afdc911bbd7db0644719d6dc3f (diff)
downloadguix-ed2dfe3955f0144bc858c66fdb751f51e9bd84fe.tar.gz
guix-ed2dfe3955f0144bc858c66fdb751f51e9bd84fe.tar.xz
gnu: Add snakemake-4.
* gnu/packages/python.scm (snakemake-4): New variable. * gnu/packages/bioinformatics.scm (pigx-bsseq, pigx-rnaseq, pigx-scrnaseq, pigx-chipseq)[inputs]: Use it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a6e3ebb9d6..e9fb9f529f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5206,6 +5206,24 @@ providing a clean and modern domain specific specification language (DSL) in
Python style, together with a fast and comfortable execution environment.")
(license license:expat)))
+;; This is currently needed for the pigx-* packages.
+(define-public snakemake-4
+ (package (inherit snakemake)
+ (version "4.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "snakemake" version))
+ (sha256
+ (base32 "0g0paia4z7w3srnqdmavq3hrb2x7qnpf81jx50njl0p7y4y0j8jv"))))
+ (propagated-inputs
+ `(("python-wrapt" ,python-wrapt)
+ ("python-requests" ,python-requests)
+ ("python-appdirs" ,python-appdirs)
+ ("python-configargparse" ,python-configargparse)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-ratelimiter" ,python-ratelimiter)))))
+
(define-public python-pyqrcode
(package
(name "python-pyqrcode")