summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2018-07-31 15:31:32 -0600
committerKenny Ballou <kballou@devnulllabs.io>2018-07-31 17:39:49 -0600
commit1c475e67e5877e12c4b85f521b8481a57cdd8dbe (patch)
tree4e412c38c27a0930dc61600c40db84fb5e5af863 /gnu
parent8f427cb50c13343ee9a1fbcf5d874ed27c0ea3b6 (diff)
downloadguix-1c475e67e5877e12c4b85f521b8481a57cdd8dbe.tar.gz
guix-1c475e67e5877e12c4b85f521b8481a57cdd8dbe.tar.xz
gnu: add python-cerberus.
* gnu/packages/python.scm: (python-cerberus, python2-cerberus): New variables. Signed-off-by: Kenny Ballou <kballou@devnulllabs.io>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6f5284cf88..4c417dc147 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13893,3 +13893,28 @@ Let's Encrypt.")
development that supports command line argument parsing, command string
validation testing and application logic.")
(license license:expat)))
+(define-public python-cerberus
+ (package
+ (name "python-cerberus")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Cerberus" version))
+ (sha256
+ (base32
+ "02l0gsm86agvxs336jx70akcygq92r1id4nii30b7v0mzd4f1hpm"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-runner" ,python-pytest-runner)))
+ (home-page "https://github.com/pyeve/cerberus")
+ (synopsis
+ "Schema and data validation tool for Python dictionaries")
+ (description
+ "Lightweight, extensible schema and data validation tool for Python
+dictionaries.")
+ (license license:isc)))
+
+(define-public python2-cerberus
+ (package-with-python2 python-cerberus))