summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2018-07-31 15:37:40 -0600
committerKenny Ballou <kballou@devnulllabs.io>2018-07-31 17:39:49 -0600
commitad3ea9d89ec604a41facfda6e881726b18b5bc06 (patch)
tree6932593df21641b701913765326da90f2a005a87 /gnu
parent1c475e67e5877e12c4b85f521b8481a57cdd8dbe (diff)
downloadguix-ad3ea9d89ec604a41facfda6e881726b18b5bc06.tar.gz
guix-ad3ea9d89ec604a41facfda6e881726b18b5bc06.tar.xz
gnu: add python-typed-ast.
* gnu/packages/python.scm: (python-typed-ast): New variable. Signed-off-by: Kenny Ballou <kballou@devnulllabs.io>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4c417dc147..bffc52476b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13893,6 +13893,29 @@ Let's Encrypt.")
development that supports command line argument parsing, command string
validation testing and application logic.")
(license license:expat)))
+(define-public python-typed-ast
+ (package
+ (name "python-typed-ast")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "typed-ast" version))
+ (sha256
+ (base32
+ "1akkpx0w4p7giyl53wjxndld5d949bls4wbvkvvfm76x1izjizjp"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-cython" ,python-cython)))
+ (home-page "https://github.com/python/typed_ast")
+ (synopsis
+ "Python 2 and 3 @code{ast} modules with type comment support")
+ (description
+ "@code{typed_ast} is a fork of Python 2.7 and 3 @code{ast} modules with
+type comment support. Unlike @code{ast}, the parsers in @code{typed_ast}
+include PEP-484 type comments and are independent of the version of Python
+under which they are run.")
+ (license license:asl2.0)))
(define-public python-cerberus
(package
(name "python-cerberus")