summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-07-02 00:08:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-07-02 00:45:19 +0200
commit6e65eb3cad1d1148eade9ed2228cdea90d531a94 (patch)
tree79238aaa30e43a5ba5448d75774de42277cda37a /gnu
parent39f516cb839af6be3420ea02705c3f914308b90b (diff)
downloadguix-6e65eb3cad1d1148eade9ed2228cdea90d531a94.tar.gz
guix-6e65eb3cad1d1148eade9ed2228cdea90d531a94.tar.xz
gnu: cdogs-sdl: Update to 0.6.7.
* gnu/packages/games.scm (cdogs-sdl): Update to 0.6.7. [source]: Use version tag.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm71
1 files changed, 34 insertions, 37 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5f43aa154c..0796e48001 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3666,46 +3666,43 @@ emerges from a sewer hole and pulls her below ground.")
license:cc-by-sa3.0)))))
(define-public cdogs-sdl
- ;; XXX: Use version 0.6.7 when it's available.
- (let ((commit "bab2031369b9ea2dbeb7eedbde10a43dd8ca83db")
- (revision "1"))
- (package
- (name "cdogs-sdl")
- (version (git-version "0.6.6" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/cxong/cdogs-sdl.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "09sfqhrrffhvxbhigvrxfmai52w01w3f9kjmixjhqvqlkhn77c9n"))))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append "-DCDOGS_DATA_DIR="
- (assoc-ref %outputs "out")
- "/share/cdogs-sdl/"))))
- (inputs
- `(("mesa" ,mesa)
- ("sdl2" ,sdl2)
- ("sdl2-image" ,sdl2-image)
- ("sdl2-mixer" ,sdl2-mixer)))
- (home-page "https://cxong.github.io/cdogs-sdl/")
- (synopsis "Classic overhead run-and-gun game")
- (description "C-Dogs SDL is a classic overhead run-and-gun game,
+ (package
+ (name "cdogs-sdl")
+ (version "0.6.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cxong/cdogs-sdl.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1frafzsj3f83xkmn4llr7g728c82lcqi424ini1hv3gv5zjgpa15"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCDOGS_DATA_DIR="
+ (assoc-ref %outputs "out")
+ "/share/cdogs-sdl/"))))
+ (inputs
+ `(("mesa" ,mesa)
+ ("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("sdl2-mixer" ,sdl2-mixer)))
+ (home-page "https://cxong.github.io/cdogs-sdl/")
+ (synopsis "Classic overhead run-and-gun game")
+ (description "C-Dogs SDL is a classic overhead run-and-gun game,
supporting up to 4 players in co-op and deathmatch modes. Customize your
player, choose from many weapons, and blast, slide and slash your way through
over 100 user-created campaigns.")
- ;; GPLv2+ for code (includes files under BSD-2 and BSD-3),
- ;; CC0/CC-BY/CC-BY-SA for assets.
- (license (list license:gpl2+
- license:bsd-2
- license:bsd-3
- license:cc0
- license:cc-by3.0
- license:cc-by-sa3.0)))))
+ ;; GPLv2+ for code (includes files under BSD-2 and BSD-3),
+ ;; CC0/CC-BY/CC-BY-SA for assets.
+ (license (list license:gpl2+
+ license:bsd-2
+ license:bsd-3
+ license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0))))
(define-public kiki
(package