summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-06-26 23:57:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-07-02 23:12:14 +0200
commit84be0e9a74e08b33e6a89caf61ec179308e7347e (patch)
treea096fb910e86538e577c45e746573f0e445378ea /gnu
parent2926e950ce47b09699dfd17efc5b565c26c20f08 (diff)
downloadguix-84be0e9a74e08b33e6a89caf61ec179308e7347e.tar.gz
guix-84be0e9a74e08b33e6a89caf61ec179308e7347e.tar.xz
gnu: Add libscrypt.
* gnu/packages/crypto.scm (libscrypt): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 338db04f53..dd86843938 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -478,6 +479,34 @@ utility as a demonstration of the @code{scrypt} key derivation function.
attacks than alternative functions such as @code{PBKDF2} or @code{bcrypt}.")
(license license:bsd-2)))
+(define-public libscrypt
+ (package
+ (name "libscrypt")
+ (version "1.21")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/technion/libscrypt.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1d76ys6cp7fi4ng1w3mz2l0p9dbr7ljbk33dcywyimzjz8bahdng"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "PREFIX=" %output)
+ "CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://lolware.net/libscrypt.html")
+ (synopsis "Password hashing library")
+ (description "@code{libscrypt} implements @code{scrypt} key derivation
+function. It is designed to be far more secure against hardware brute-force
+attacks than alternative functions such as @code{PBKDF2} or @code{bcrypt}.")
+ (license license:bsd-3)))
+
(define-public perl-math-random-isaac-xs
(package
(name "perl-math-random-isaac-xs")