summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-07-02 23:27:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-07-02 23:27:07 +0200
commitc729901583981381ef04f3be57b28e92bd81090b (patch)
tree9efba751b1a6b55c7d36e5f1898b60269eef927a /gnu
parent929d4d2f4ad8f7d1c04793ac2e436e7e0c14edd5 (diff)
downloadguix-c729901583981381ef04f3be57b28e92bd81090b.tar.gz
guix-c729901583981381ef04f3be57b28e92bd81090b.tar.xz
gnu: python-duniterpy: Change module.
* gnu/packages/python-crypto.scm (python-duniterpy): Move... * gnu/packages/finance.scm: ... here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm44
-rw-r--r--gnu/packages/python-crypto.scm44
2 files changed, 44 insertions, 44 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 787510cb37..e69b3cabc4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -755,6 +755,50 @@ Luhn and family of ISO/IEC 7064 check digit algorithms. ")
(define-public python2-stdnum
(package-with-python2 python-stdnum))
+(define-public python-duniterpy
+ (package
+ (name "python-duniterpy")
+ (version "0.43.2")
+ (source
+ (origin
+ (method git-fetch)
+ ;; Pypi's default URI is missing "requirements.txt" file.
+ (uri (git-reference
+ (url "https://github.com/duniter/duniter-python-api.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ch4f150k1p1l876pp08p5rxqhpv5xfbxdw6njcmr06hspv8v8x4"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; Among 108 tests, a single one is failing: FAIL:
+ ;; test_from_pubkey. Remove it.
+ (add-after 'unpack 'remove-failing-test
+ (lambda _
+ (delete-file "tests/documents/test_crc_pubkey.py")
+ #t)))))
+ (propagated-inputs
+ `(("python-aiohttp" ,python-aiohttp)
+ ("python-base58" ,python-base58)
+ ("python-jsonschema" ,python-jsonschema)
+ ("python-libnacl" ,python-libnacl)
+ ("python-pylibscrypt" ,python-pylibscrypt)
+ ("python-pypeg2" ,python-pypeg2)))
+ (home-page "https://github.com/duniter/duniter-python-api")
+ (synopsis "Python implementation of Duniter API")
+ (description "@code{duniterpy} is an implementation of
+@uref{https://github.com/duniter/duniter/, duniter} API. Its
+main features are:
+@itemize
+@item Supports Duniter's Basic Merkle API and protocol
+@item Asynchronous
+@item Duniter signing key
+@end itemize")
+ (license license:gpl3+)))
+
(define-public silkaj
(package
(name "silkaj")
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index 80875ad45a..2d865a92b3 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -944,50 +944,6 @@ been constructed to maintain extensive documentation on how to use
@code{NaCl} as well as being completely portable.")
(license license:asl2.0)))
-(define-public python-duniterpy
- (package
- (name "python-duniterpy")
- (version "0.43.2")
- (source
- (origin
- (method git-fetch)
- ;; Pypi's default URI is missing "requirements.txt" file.
- (uri (git-reference
- (url "https://github.com/duniter/duniter-python-api.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ch4f150k1p1l876pp08p5rxqhpv5xfbxdw6njcmr06hspv8v8x4"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; Among 108 tests, a single one is failing: FAIL:
- ;; test_from_pubkey. Remove it.
- (add-after 'unpack 'remove-failing-test
- (lambda _
- (delete-file "tests/documents/test_crc_pubkey.py")
- #t)))))
- (propagated-inputs
- `(("python-aiohttp" ,python-aiohttp)
- ("python-base58" ,python-base58)
- ("python-jsonschema" ,python-jsonschema)
- ("python-libnacl" ,python-libnacl)
- ("python-pylibscrypt" ,python-pylibscrypt)
- ("python-pypeg2" ,python-pypeg2)))
- (home-page "https://github.com/duniter/duniter-python-api")
- (synopsis "Python implementation of Duniter API")
- (description "@code{duniterpy} is an implementation of
-@uref{https://github.com/duniter/duniter/, duniter} API. Its
-main features are:
-@itemize
-@item Supports Duniter's Basic Merkle API and protocol
-@item Asynchronous
-@item Duniter signing key
-@end itemize")
- (license license:gpl3+)))
-
(define-public python-scrypt
(package
(name "python-scrypt")