summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 072c8bb1f1..692626350c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5859,6 +5859,34 @@ your program. Contains warnings that don't belong in @code{pyflakes} and
@code{pycodestyle}.")
(license license:expat)))
+(define-public python-flake8-pyi
+ (package
+ (name "python-flake8-pyi")
+ (version "18.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-pyi" version))
+ (sha256
+ (base32
+ "0m4sgnypgiq1hb0jwl0zpqmdx505bz76n6pcpj4vi8qq252f4rry"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-attrs" ,python-attrs)
+ ("python-flake8" ,python-flake8)
+ ("python-mccabe" ,python-mccabe)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-pyflakes" ,python-pyflakes)))
+ (arguments
+ ;; FIXME: Enable tests when https://github.com/ambv/flake8-pyi/pulls/13
+ ;; is merged and https://github.com/ambv/flake8-pyi/issues/14 is closed.
+ '(#:tests? #f))
+ (home-page "https://github.com/ambv/flake8-pyi")
+ (synopsis
+ "Plugin to @code{flake8} to lint @code{.pyi} files")
+ (description
+ "A plugin for @code{flake8} to enable linting @code{.pyi} files.")
+ (license license:expat)))
(define-public python-mistune
(package