summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm7
-rw-r--r--gnu/packages/image.scm8
-rw-r--r--gnu/packages/kde.scm2
-rw-r--r--gnu/packages/libedit.scm2
4 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3bb5e3074a..ac87de540e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -373,14 +373,13 @@ access to the full zlib feature set.")
(arguments
`(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
(home-page "https://github.com/bos/text")
- (synopsis
- "Efficient packed Unicode text type library.")
+ (synopsis "Efficient packed Unicode text type library")
(description
"An efficient packed, immutable Unicode text type (both strict and
lazy), with a powerful loop fusion optimization framework.
The 'Text' type represents Unicode character strings, in a time and
-space-efficient manner. This package provides text processing
+space-efficient manner. This package provides text processing
capabilities that are optimized for performance critical use, both
in terms of large data quantities and high speed.")
(license bsd-3)))
@@ -870,7 +869,7 @@ package into this package.")
(home-page "https://github.com/haskell/HTTP")
(synopsis "Library for client-side HTTP")
(description
- "The HTTP package supports client-side web programming in Haskell. It
+ "The HTTP package supports client-side web programming in Haskell. It
lets you set up HTTP connections, transmitting requests and processing the
responses coming back.")
(license bsd-3)))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index c24ec99375..89590cc5ad 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -555,10 +555,10 @@ multi-dimensional image processing.")
(synopsis "Lossless and lossy image compression")
(description
"WebP is a new image format that provides lossless and lossy compression
-for images. WebP lossless images are 26% smaller in size compared to
-PNGs. WebP lossy images are 25-34% smaller in size compared to JPEG images at
-equivalent SSIM index. WebP supports lossless transparency (also known as
-alpha channel) with just 22% additional bytes. Transparency is also supported
+for images. WebP lossless images are 26% smaller in size compared to
+PNGs. WebP lossy images are 25-34% smaller in size compared to JPEG images at
+equivalent SSIM index. WebP supports lossless transparency (also known as
+alpha channel) with just 22% additional bytes. Transparency is also supported
with lossy compression and typically provides 3x smaller file sizes compared
to PNG when lossy compression is acceptable for the red/green/blue color
channels.")
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index c6556865c2..1409e7c0b1 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -224,6 +224,6 @@ calculation of sha1 for every file crawled
(arguments
`(#:tests? #f)) ; no test target
(home-page "http://www.kde.org/")
- (synopsis "oxygen icon theme for the KDE desktop")
+ (synopsis "Oxygen icon theme for the KDE desktop")
(description "KDE desktop environment")
(license lgpl3+)))
diff --git a/gnu/packages/libedit.scm b/gnu/packages/libedit.scm
index fcf5ab4c74..1d7b5b6a5f 100644
--- a/gnu/packages/libedit.scm
+++ b/gnu/packages/libedit.scm
@@ -42,7 +42,7 @@
(synopsis "NetBSD Editline library")
(description
"This is an autotool- and libtoolized port of the NetBSD Editline
-library (libedit). This Berkeley-style licensed command line editor library
+library (libedit). This Berkeley-style licensed command line editor library
provides generic line editing, history, and tokenization functions, similar to
those found in GNU Readline.")
(license bsd-3)))