aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJunio C Hamano <junkio@cox.net>2006-09-29 00:34:51 -0700
committerJunio C Hamano <junkio@cox.net>2006-09-29 18:52:38 -0700
commitf7661ce0b8ee068e53d57249625199dda2829e30 (patch)
treefd31822f80f8929d0bdd75e6e376c3cb9199dc05 /configure.ac
parent18b0fc1ce1ef92716d4c5d5c7acd5d5a61a0a556 (diff)
downloadgit-f7661ce0b8ee068e53d57249625199dda2829e30.tar.gz
git-f7661ce0b8ee068e53d57249625199dda2829e30.tar.xz
Remove -fPIC which was only needed for Git.xs
The distinction between BASIC_ vs ALL_ is still kept, since it is not Git.xs specific -- we could face the same issue when we do other language bindings (e.g. Python). Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 0f93f6fe2..819282691 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,13 +96,6 @@ AC_SUBST(PYTHON_PATH)
AC_MSG_NOTICE([CHECKS for programs])
#
AC_PROG_CC([cc gcc])
-if test -n "$GCC"; then
- PIC_FLAG="-fPIC"
-else
- AC_CHECK_DECL(__SUNPRO_C, [CFLAGS="$CFLAGS -xO3"; PIC_FLAG="-KPIC"])
-fi
-AC_SUBST(PIC_FLAG)
-
#AC_PROG_INSTALL # needs install-sh or install.sh in sources
AC_CHECK_TOOL(AR, ar, :)
AC_CHECK_PROGS(TAR, [gtar tar])