aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Narebski <jnareb@gmail.com>2006-07-08 23:07:10 +0200
committerJunio C Hamano <junkio@cox.net>2006-07-09 02:20:40 -0700
commiteb0f255d6144af26361b12cb38aae9c23581a955 (patch)
tree98992715cad0191e0741e54adaf1838ce9c6c9c5 /configure.ac
parentd3a6db981179a1dc772768ff6af0414d17848d93 (diff)
downloadgit-eb0f255d6144af26361b12cb38aae9c23581a955.tar.gz
git-eb0f255d6144af26361b12cb38aae9c23581a955.tar.xz
autoconf: Checks for typedefs, structures, and compiler characteristics.
./configure script checks now for existence of the following types, structures, and structure members: * dirent.d_ino in <dirent.h> (NO_D_INO_IN_DIRENT) * dirent.d_type in <dirent.h> (NO_D_TYPE_IN_DIRENT) * 'struct sockaddr_storage' in <netinet/in.h> (NO_SOCKADDR_STORAGE) Signed-off-by: Jakub Narebski <jnareb@gmail.com> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e68d4163c..cb812584c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,13 +48,24 @@ AC_DEFUN([GIT_CONF_APPEND_LINE],
## Checks for typedefs, structures, and compiler characteristics.
+AC_MSG_NOTICE([CHECKS for typedefs, structures, and compiler characteristics])
+
# Define NO_D_INO_IN_DIRENT if you don't have d_ino in your struct dirent.
-#
+AC_CHECK_MEMBER(struct dirent.d_ino,[],
+GIT_CONF_APPEND_LINE(NO_D_INO_IN_DIRENT=YesPlease),
+[#include <dirent.h>])
+
# Define NO_D_TYPE_IN_DIRENT if your platform defines DT_UNKNOWN but lacks
# d_type in struct dirent (latest Cygwin -- will be fixed soonish).
-#
+AC_CHECK_MEMBER(struct dirent.d_type,[],
+GIT_CONF_APPEND_LINE(NO_D_TYPE_IN_DIRENT=YesPlease),
+[#include <dirent.h>])
+
# Define NO_SOCKADDR_STORAGE if your platform does not have struct
# sockaddr_storage.
+AC_CHECK_TYPE(struct sockaddr_storage,[],
+GIT_CONF_APPEND_LINE(NO_SOCKADDR_STORAGE=YesPlease),
+[#include <netinet/in.h>])
## Checks for library functions.