aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDennis Stosberg <dennis@stosberg.net>2006-08-15 11:01:31 +0200
committerJunio C Hamano <junkio@cox.net>2006-08-15 03:13:47 -0700
commit60a144f28047b4fa0e4a795972c483fa85a7d3c8 (patch)
treee06f3ff36980e068c9a3a036f2606122f8134f96 /configure.ac
parentd7b6c3c0f54b951c85cd41c6e6571c65cf090111 (diff)
downloadgit-60a144f28047b4fa0e4a795972c483fa85a7d3c8.tar.gz
git-60a144f28047b4fa0e4a795972c483fa85a7d3c8.tar.xz
Fix compilation with Sun CC
- Add the CFLAGS variable to config.mak.in to override the Makefile's default, which is gcc-specific and won't work with Sun CC. - Prefer "cc" over "gcc", because Pasky's Git.pm will not compile with gcc on Solaris at all. On Linux and the free BSDs "cc" is linked to "gcc" anyway. - Set correct flag to generate position-independent code. - Add "-xO3" (= use default optimization level) to CFLAGS. Signed-off-by: Dennis Stosberg <dennis@stosberg.net> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 36f9cd94d..0f93f6fe2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,7 +95,14 @@ AC_SUBST(PYTHON_PATH)
## Checks for programs.
AC_MSG_NOTICE([CHECKS for programs])
#
-AC_PROG_CC
+AC_PROG_CC([cc gcc])
+if test -n "$GCC"; then
+ PIC_FLAG="-fPIC"
+else
+ AC_CHECK_DECL(__SUNPRO_C, [CFLAGS="$CFLAGS -xO3"; PIC_FLAG="-KPIC"])
+fi
+AC_SUBST(PIC_FLAG)
+
#AC_PROG_INSTALL # needs install-sh or install.sh in sources
AC_CHECK_TOOL(AR, ar, :)
AC_CHECK_PROGS(TAR, [gtar tar])