aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Nelissen <marcone@xs4all.nl>2009-06-08 20:46:38 -0700
committerJunio C Hamano <gitster@pobox.com>2009-06-08 21:18:02 -0700
commit934f82a7d424ea9a8fa0ae83020689d11efc2bff (patch)
treebbc0c841ad1f07353dfb9943dbfb41d9a6021cc4 /configure.ac
parent801a011dcf41f0415dee81f0500673e058bdee30 (diff)
downloadgit-934f82a7d424ea9a8fa0ae83020689d11efc2bff.tar.gz
git-934f82a7d424ea9a8fa0ae83020689d11efc2bff.tar.xz
fix handling of iconv configuration options
Fix the way in which the configure script handles --without-iconv (and --with-iconv=no), which it used to essentially ignore. Also fix the way the configure script determines the value of NEEDS_LIBICONV, which would be incorrectly set to 'YesPlease' on systems that lack iconv entirely. Signed-off-by: Marco Nelissen <marcone@xs4all.nl> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e728bca3..25fbe3bb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -385,6 +385,8 @@ AC_SUBST(NO_EXPAT)
# some Solaris installations).
# Define NO_ICONV if neither libc nor libiconv support iconv.
+if test -z "$NO_ICONV"; then
+
GIT_STASH_FLAGS($ICONVDIR)
AC_DEFUN([ICONVTEST_SRC], [
@@ -431,6 +433,12 @@ GIT_UNSTASH_FLAGS($ICONVDIR)
AC_SUBST(NEEDS_LIBICONV)
AC_SUBST(NO_ICONV)
+if test -n "$NO_ICONV"; then
+ NEEDS_LIBICONV=
+fi
+
+fi
+
#
# Define NO_DEFLATE_BOUND if deflateBound is missing from zlib.