aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Schiele <rschiele@gmail.com>2007-08-01 06:30:35 +0200
committerJunio C Hamano <gitster@pobox.com>2007-07-31 22:36:55 -0700
commit10861beaa89a4cec61e04dd4954452da24b7a757 (patch)
tree7b5ce0c9867e0d8b71f5edf4b89d2ed8d3be3ae0 /configure.ac
parent4b7f59af2a5b072a0a3950c956842e4d6223a167 (diff)
downloadgit-10861beaa89a4cec61e04dd4954452da24b7a757.tar.gz
git-10861beaa89a4cec61e04dd4954452da24b7a757.tar.xz
make the name of the library directory a config option
Introduce new makefile variable lib to hold the name of the lib directory ("lib" by default). Also introduce a switch for configure to specify this name with --with-lib=ARG. This is useful for systems that use a different name than "lib" (like "lib64" on some 64 bit Linux architectures). Signed-off-by: Robert Schiele <rschiele@gmail.com> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2f196585..84fd7f1e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,6 +69,17 @@ fi \
## Site configuration related to programs (before tests)
## --with-PACKAGE[=ARG] and --without-PACKAGE
#
+# Set lib to alternative name of lib directory (e.g. lib64)
+AC_ARG_WITH([lib],
+ [AS_HELP_STRING([--with-lib=ARG],
+ [ARG specifies alternative name for lib directory])],
+ [if test "$withval" = "no" -o "$withval" = "yes"; then \
+ AC_MSG_WARN([You should provide name for --with-lib=ARG]); \
+else \
+ GIT_CONF_APPEND_LINE(lib=$withval); \
+fi; \
+],[])
+#
# Define SHELL_PATH to provide path to shell.
GIT_ARG_SET_PATH(shell)
#