aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJunio C Hamano <gitster@pobox.com>2010-06-16 16:33:47 -0700
committerJunio C Hamano <gitster@pobox.com>2010-06-16 16:33:47 -0700
commit7e74a73e6b57652c2710a9814a5449afeec5bd44 (patch)
treefe7f5114cb479268cbead41264e95b12041c3520 /configure.ac
parent356169c1f66287629ea08e8c9c6e27b00ff8707a (diff)
parentbb15e38281aab342a0e3ca7d5663b0c3f9d5e72e (diff)
downloadgit-7e74a73e6b57652c2710a9814a5449afeec5bd44.tar.gz
git-7e74a73e6b57652c2710a9814a5449afeec5bd44.tar.xz
Merge branch 'cw/maint-exec-defpath' into maint
* cw/maint-exec-defpath: autoconf: Check if <paths.h> exists and set HAVE_PATHS_H exec_cmd.c: replace hard-coded path list with one from <paths.h>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f4d7372ef..71038fcf1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -724,6 +724,12 @@ AC_CHECK_HEADER([libgen.h],
[NO_LIBGEN_H=YesPlease])
AC_SUBST(NO_LIBGEN_H)
#
+# Define HAVE_PATHS_H if you have paths.h.
+AC_CHECK_HEADER([paths.h],
+[HAVE_PATHS_H=YesPlease],
+[HAVE_PATHS_H=])
+AC_SUBST(HAVE_PATHS_H)
+#
# Define NO_STRCASESTR if you don't have strcasestr.
GIT_CHECK_FUNC(strcasestr,
[NO_STRCASESTR=],