aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRyan Anderson <ryan@michonline.com>2005-07-23 15:26:32 -0400
committerJunio C Hamano <junkio@cox.net>2005-07-26 22:23:19 -0700
commita977d2cf589c8e4d66e53e9399a61ef08a8ddcad (patch)
tree2d652d8b9a8d2457a6e7de7060c6077014fed767 /debian
parentbdf25142aaac016f4d992001f336d53ab4fbc75e (diff)
downloadgit-a977d2cf589c8e4d66e53e9399a61ef08a8ddcad.tar.gz
git-a977d2cf589c8e4d66e53e9399a61ef08a8ddcad.tar.xz
Deb Packaging fixes: Build against Mozilla libs for Debian, conflict with "git"
This patch includes two fixes to the git-core Debian package: * Conflict with the GNU Interactive Tools package, which _also_ wants to install /usr/bin/git. * Compile against the unencumbered Mozilla SHA1 code, instead of the iffy OpenSSL code, as much as possible. This makes it easier to get the package included for distribution with Debian. This has been based upon the original patch by Sebastian Kuzminsky <seb@highlab.com>, but has been fixed up based upon feedback. Signed-off-by: Ryan Anderson <ryan@michonline.com> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules14
3 files changed, 27 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 7cbf2f4db..1e62b783b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+git-core (0.99-2) unstable; urgency=low
+
+ * Conflict with the GNU Interactive Tools package, which also installs
+ /usr/bin/git.
+ * Use the Mozilla SHA1 code and/or the PPC assembly in preference to
+ OpenSSL. This is only a partial fix for the license issues with OpenSSL.
+ * Minor tweaks to the Depends.
+
+ -- Ryan Anderson <ryan@michonline.com> Sat, 23 Jul 2005 14:15:00 -0400
+
git-core (0.99-1) unstable; urgency=low
* Update deb package support to build correctly.
diff --git a/debian/control b/debian/control
index a774a629b..98c81c76f 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,9 @@ Standards-Version: 3.6.1
Package: git-core
Architecture: any
-Depends: ${misc:Depends}, shellutils, diff, rsync, rcs
+Depends: ${shlibs:Depends}, ${misc:Depends}, patch, diff, rcs
+Recommends: rsync, curl, ssh
+Conflicts: git
Description: The git content addressable filesystem
GIT comes in two layers. The bottom layer is merely an extremely fast
and flexible filesystem-based database designed to store directory trees
diff --git a/debian/rules b/debian/rules
index aff43b836..67830b03b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,20 @@ else
endif
export CFLAGS
+#
+# On PowerPC we compile against the hand-crafted assembly, on all
+# other architectures we compile against GPL'ed sha1 code lifted
+# from Mozilla. OpenSSL is strangely licensed and best avoided
+# in Debian.
+#
+HOST_ARCH=$(shell dpkg-architecture -qDEB_HOST_ARCH)
+ifeq (${HOST_ARCH},powerpc)
+ export PPC_SHA1=YesPlease
+else
+ export MOZILLA_SHA1=YesPlease
+endif
+
+
PREFIX := /usr
MANDIR := /usr/share/man/