aboutsummaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL10
1 files changed, 10 insertions, 0 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index dd6105677..54e8b20ed 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -8,9 +8,19 @@ instlibdir:
MAKE_FRAG
}
+my %pm = ('Git.pm' => '$(INST_LIBDIR)/Git.pm');
+
+# We come with our own bundled Error.pm. It's not in the set of default
+# Perl modules so install it if it's not available on the system yet.
+eval { require 'Error' };
+if ($@) {
+ $pm{'Error.pm'} = '$(INST_LIBDIR)/Error.pm';
+}
+
WriteMakefile(
NAME => 'Git',
VERSION_FROM => 'Git.pm',
+ PM => \%pm,
MYEXTLIB => '../libgit.a',
INC => '-I. -I..',
);