aboutsummaryrefslogtreecommitdiff
path: root/perl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'perl/Makefile.PL')
-rw-r--r--perl/Makefile.PL7
1 files changed, 2 insertions, 5 deletions
diff --git a/perl/Makefile.PL b/perl/Makefile.PL
index 9b117fd0d..320253eb8 100644
--- a/perl/Makefile.PL
+++ b/perl/Makefile.PL
@@ -13,13 +13,10 @@ my %pm = ('Git.pm' => '$(INST_LIBDIR)/Git.pm');
# We come with our own bundled Error.pm. It's not in the set of default
# Perl modules so install it if it's not available on the system yet.
eval { require Error };
-if ($@) {
+if ($@ || $Error::VERSION < 0.15009) {
$pm{'private-Error.pm'} = '$(INST_LIBDIR)/Error.pm';
}
-my %extra;
-$extra{DESTDIR} = $ENV{DESTDIR} if $ENV{DESTDIR};
-
# redirect stdout, otherwise the message "Writing perl.mak for Git"
# disrupts the output for the target 'instlibdir'
open STDOUT, ">&STDERR";
@@ -29,5 +26,5 @@ WriteMakefile(
VERSION_FROM => 'Git.pm',
PM => \%pm,
MAKEFILE => 'perl.mak',
- %extra
+ INSTALLSITEMAN3DIR => '$(SITEPREFIX)/share/man/man3'
);