summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenny Ballou <kballou@devnulllabs.io>2018-08-08 07:43:06 -0600
committerKenny Ballou <kballou@devnulllabs.io>2018-08-12 20:48:18 -0600
commit4dc85403a210102836c55a0fdf0ac084abd1288b (patch)
treeecb736a63306b288b7d3364cd52592fbdd55cfa7
parenta9ab53644f5fea90a507d137e29941f660c9c6f0 (diff)
downloadgentoo-sakura-update.tar.gz
gentoo-sakura-update.tar.xz
x11-terms/sakura: add new ebuild for version 3.6.0.sakura-update
Bug: https://bugs.gentoo.org/657256 Package-Manager: Portage-3.3.40, Repoman-2.3.9
-rw-r--r--x11-terms/sakura/Manifest1
-rw-r--r--x11-terms/sakura/sakura-3.6.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-terms/sakura/Manifest b/x11-terms/sakura/Manifest
index 1ac194a7bd7..e6c31dce20d 100644
--- a/x11-terms/sakura/Manifest
+++ b/x11-terms/sakura/Manifest
@@ -1 +1,2 @@
DIST sakura-3.5.0.tar.bz2 55432 BLAKE2B 9accd09eac359b64637ff5c318e50e32f5bfa27cf7fb5d4a99c91391e14f145020bd19077e20585b78149e5ac5f281abaf1098dbbaf111e54fd5ad5fbb2f4887 SHA512 20c691342c68a2a6f7397da754c83b19c7622e25984ae9fe9fef47492e19cd7589dd9d1bd2ccb82bd9c6ab82f92c97c1b742795434a101a0e169c6f901f40d9e
+DIST sakura-3.6.0.tar.bz2 56044 BLAKE2B 746de744ad562c4202acf4cb6803917530bde6edb13799630124e64e3e423ee423770cdebd5f8f42b5c2bd56b8863c82eb2015c65b2f168933c87337026c1313 SHA512 4b9d2c15305a2b9a193031194afc0b50deeb32ae52f8b13967801cd57aa71424d7dedf0a9aedf7470aef8b58d8341c85ae37ef67b941b8b97912eb845c5df08f
diff --git a/x11-terms/sakura/sakura-3.6.0.ebuild b/x11-terms/sakura/sakura-3.6.0.ebuild
new file mode 100644
index 00000000000..36cb611be37
--- /dev/null
+++ b/x11-terms/sakura/sakura-3.6.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils eutils flag-o-matic gnome2-utils xdg-utils
+
+DESCRIPTION="Terminal emulator based on GTK and VTE"
+HOMEPAGE="http://www.pleyades.net/david/projects/sakura/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.20:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libX11
+ x11-libs/vte:2.91
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-lang/perl-5.10.1
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.3-flags.patch
+)
+
+src_prepare() {
+ sed -i "/FILES INSTALL/d" CMakeLists.txt || die
+
+ strip-linguas -i po/
+ local lingua
+ for lingua in po/*.po; do
+ lingua="${lingua/po\/}"
+ lingua="${lingua/.po}"
+ if ! has ${lingua} ${LINGUAS}; then
+ rm po/${lingua}.po || die
+ fi
+ done
+
+ cmake-utils_src_prepare
+ # sakura.c:1740:3: warning: implicit declaration of function ‘readlink’
+ # [-Wimplicit-function-declaration]
+ append-cppflags -D_DEFAULT_SOURCE
+
+ # sakura.c:1348:9: error: ‘for’ loop initial declarations are only allowed
+ # in C99 or C11 mode
+ append-cflags -std=c99
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}