summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-21 13:35:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-21 13:37:24 +0100
commit0957e5408fd94edd306b8a495b928d117f5f29d1 (patch)
tree763a97d559fc5a66dad56ddc68d959be628aa174
parent436f7416de80817975bf5b7b6e06458d26404d68 (diff)
downloadgentoo-0957e5408fd94edd306b8a495b928d117f5f29d1.tar.gz
gentoo-0957e5408fd94edd306b8a495b928d117f5f29d1.tar.xz
media-sound/fluidsynth: bump to 1.1.9 and update remoteid
Package-Manager: Portage-2.3.20, Repoman-2.3.6
-rw-r--r--media-sound/fluidsynth/Manifest1
-rw-r--r--media-sound/fluidsynth/fluidsynth-1.1.9.ebuild70
-rw-r--r--media-sound/fluidsynth/metadata.xml2
3 files changed, 72 insertions, 1 deletions
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index 47de45d6129..1c6265ecf9e 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1 +1,2 @@
DIST fluidsynth-1.1.6.tar.gz 958735 BLAKE2B 9be1e72238545d78f2aded9e98336639ba83d2272b3247ac86609e84331fb8517eb29b505d269719196468bdbf645496c9f4f4426ac232b16f19b3b8b1c3450f SHA512 2dcb8a8a1634273cc93c45b6e21b87ac45a023c768cffdadda0a4e611eab8d5bbea0e1ba59e5f147488054cfa6fcaf561399ae275a665c76082b8738a80778bb
+DIST fluidsynth-1.1.9.tar.gz 630651 BLAKE2B 2e6faa1126778a98b1960146046490331f943dfe78dcbf66aeaac16deda3ea0bca2eca747e7041ba752d136360b2003ae89b0d936df78a6cd9d5024bd3cd834e SHA512 9bbe9143dc55a0e10e33efd62698e28b598a7ede95d44f193a93c5e29920c7b6d08f7f5ba96bd2c1c42a4b184134d4e811f643fdc0077be714c0cf72635de235
diff --git a/media-sound/fluidsynth/fluidsynth-1.1.9.ebuild b/media-sound/fluidsynth/fluidsynth-1.1.9.ebuild
new file mode 100644
index 00000000000..18d329d31b2
--- /dev/null
+++ b/media-sound/fluidsynth/fluidsynth-1.1.9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-multilib flag-o-matic
+
+DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
+HOMEPAGE="http://www.fluidsynth.org/"
+SRC_URI="https://github.com/FluidSynth/fluidsynth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa dbus debug examples ipv6 jack ladspa lash portaudio pulseaudio readline sndfile"
+
+RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}]
+ lash? ( >=media-sound/lash-0.5.4-r2[${MULTILIB_USEDEP}] ) )
+ dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ jack? ( virtual/jack[${MULTILIB_USEDEP}] )
+ ladspa? ( >=media-libs/ladspa-sdk-1.13-r2[${MULTILIB_USEDEP}]
+ >=media-libs/ladspa-cmt-1.16-r3[${MULTILIB_USEDEP}] )
+ pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
+ portaudio? ( >=media-libs/portaudio-19_pre20111121-r1[${MULTILIB_USEDEP}] )
+ readline? ( >=sys-libs/readline-6.2_p5-r1:0=[${MULTILIB_USEDEP}] )
+ sndfile? ( >=media-libs/libsndfile-1.0.25[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+src_configure() {
+ # autotools based build system has AC_CHECK_LIB(pthread, pthread_create) wrt
+ # bug #436762
+ append-flags -pthread
+
+ mycmakeargs=(
+ $(cmake-utils_use alsa enable-alsa)
+ $(cmake-utils_use dbus enable-dbus)
+ $(cmake-utils_use debug enable-debug)
+ $(cmake-utils_use ipv6 enable-ipv6)
+ $(cmake-utils_use jack enable-jack)
+ -Denable-ladcca=OFF
+ $(cmake-utils_use ladspa enable-ladspa)
+ $(cmake-utils_use sndfile enable-libsndfile)
+ $(cmake-utils_use portaudio enable-portaudio)
+ $(cmake-utils_use pulseaudio enable-pulseaudio)
+ $(cmake-utils_use readline enable-readline)
+ )
+
+ if use alsa; then
+ mycmakeargs+=( $(cmake-utils_use lash enable-lash) )
+ else
+ mycmakeargs+=( -Denable-lash=OFF )
+ fi
+
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ dodoc AUTHORS NEWS README.md THANKS TODO doc/*.txt
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ if use examples; then
+ docinto examples
+ dodoc doc/*.c
+ fi
+}
diff --git a/media-sound/fluidsynth/metadata.xml b/media-sound/fluidsynth/metadata.xml
index 439f7cda7dd..81333c2546c 100644
--- a/media-sound/fluidsynth/metadata.xml
+++ b/media-sound/fluidsynth/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Sound project</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">fluidsynth</remote-id>
+ <remote-id type="github">FluidSynth/fluidsynth</remote-id>
</upstream>
</pkgmetadata>