summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-06 14:26:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-06 14:30:28 +0200
commit0ba9bbdcb7d2401d7211ed560fdbf0b4f293c19e (patch)
tree398330727690ce0b079ec98d297bce4d3696cb8b
parent299db0c091c24a76064f586a9569e19ef81c78a7 (diff)
downloadgentoo-0ba9bbdcb7d2401d7211ed560fdbf0b4f293c19e.tar.gz
gentoo-0ba9bbdcb7d2401d7211ed560fdbf0b4f293c19e.tar.xz
dev-ml/react: convert to opam.eclass
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-ml/react/react-1.2.1.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-ml/react/react-1.2.1.ebuild b/dev-ml/react/react-1.2.1.ebuild
index 5793d0daca0..de34f259d5a 100644
--- a/dev-ml/react/react-1.2.1.ebuild
+++ b/dev-ml/react/react-1.2.1.ebuild
@@ -3,6 +3,8 @@
EAPI="5"
+inherit opam
+
DESCRIPTION="OCaml module for functional reactive programming"
HOMEPAGE="http://erratique.ch/software/react https://github.com/dbuenzli/react"
SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
@@ -12,10 +14,9 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
IUSE="test"
-RDEPEND=">=dev-lang/ocaml-3.12:="
+RDEPEND=""
DEPEND="${RDEPEND}
dev-ml/findlib
- dev-ml/opam
>=dev-ml/topkg-0.9
"
@@ -28,12 +29,3 @@ src_compile() {
src_test() {
ocaml pkg/pkg.ml test || die
}
-
-src_install() {
- opam-installer \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- || die
- dodoc CHANGES.md README.md TODO.md
-}