summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-01-22 10:39:32 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-01-22 10:39:32 +0000
commit1c48f49cea102f0d494f7d2f25c653317cf5c657 (patch)
treef815ed63d934f2f8505bdd2a76b75a85ffe9a41a
parent5e0dabb435337913ced9d92b3f9ff5ee0fff9967 (diff)
parent41f25eb21b8f14a516847ab494208539fec6ec8d (diff)
downloadgentoo-1c48f49cea102f0d494f7d2f25c653317cf5c657.tar.gz
gentoo-1c48f49cea102f0d494f7d2f25c653317cf5c657.tar.xz
net-p2p/amule: Resolve merge conflicts.
-rw-r--r--net-p2p/amule/amule-2.3.1-r1.ebuild31
-rw-r--r--net-p2p/amule/files/amuled.initd11
-rw-r--r--net-p2p/amule/files/amuleweb.initd13
3 files changed, 26 insertions, 29 deletions
diff --git a/net-p2p/amule/amule-2.3.1-r1.ebuild b/net-p2p/amule/amule-2.3.1-r1.ebuild
index 99b75d04444..565019e13b0 100644
--- a/net-p2p/amule/amule-2.3.1-r1.ebuild
+++ b/net-p2p/amule/amule-2.3.1-r1.ebuild
@@ -3,9 +3,8 @@
# $Id$
EAPI=5
-WX_GTK_VER="3.0"
-inherit eutils flag-o-matic wxwidgets user
+inherit eutils wxwidgets user
MY_P=${PN/m/M}-${PV}
S="${WORKDIR}"/${MY_P}
@@ -19,19 +18,17 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="daemon debug geoip nls remote stats unicode upnp +X"
-RDEPEND="
- >=dev-libs/crypto++-5
+DEPEND=">=dev-libs/crypto++-5
+ sys-libs/binutils-libs:0=
>=sys-libs/zlib-1.2.1
- stats? ( >=media-libs/gd-2.0.26[jpeg] )
+ >=x11-libs/wxGTK-2.8.12:2.8[X?]
+ stats? ( >=media-libs/gd-2.0.26:=[jpeg] )
geoip? ( dev-libs/geoip )
upnp? ( >=net-libs/libupnp-1.6.6 )
remote? ( >=media-libs/libpng-1.2.0:0=
- unicode? ( >=media-libs/gd-2.0.26 ) )
- X? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
- !X? ( x11-libs/wxGTK:${WX_GTK_VER} )
- !net-p2p/imule
-"
-DEPEND="${RDEPEND}"
+ unicode? ( >=media-libs/gd-2.0.26:= ) )
+ !net-p2p/imule"
+RDEPEND="${DEPEND}"
pkg_setup() {
if use stats && ! use X; then
@@ -52,15 +49,13 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.2.6-fallocate.diff
# Bug 412371
epatch "${FILESDIR}"/${PN}-2.3.1-gcc47.patch
-
- # https://bugs.gentoo.org/show_bug.cgi?id=465084
- epatch "${FILESDIR}"/${PN}-2.3.1-wx3.0.patch
- epatch "${FILESDIR}"/${PN}-2.3.1-build.patch
}
src_configure() {
local myconf
+ WX_GTK_VER="2.8"
+
if use X; then
einfo "wxGTK with X support will be used"
need-wxwidgets unicode
@@ -84,10 +79,10 @@ src_configure() {
fi
econf \
- --with-wx-config=${WX_CONFIG} \
+ --with-denoise-level=0 \
+ --with-wx-config="${WX_CONFIG}" \
--enable-amulecmd \
$(use_enable debug) \
- $(use_enable !debug optimize) \
$(use_enable daemon amule-daemon) \
$(use_enable geoip) \
$(use_enable nls) \
@@ -99,7 +94,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
if use daemon; then
newconfd "${FILESDIR}"/amuled.confd amuled
diff --git a/net-p2p/amule/files/amuled.initd b/net-p2p/amule/files/amuled.initd
index 9b83458b380..082e2ffe15f 100644
--- a/net-p2p/amule/files/amuled.initd
+++ b/net-p2p/amule/files/amuled.initd
@@ -22,12 +22,13 @@ start() {
fi
ebegin "Starting aMule Daemon"
- env HOME="${AMULEHOME}" start-stop-daemon --start \
+ start-stop-daemon --start \
--quiet --background \
--make-pidfile --pidfile /var/run/amuled.pid \
- -c ${AMULEUSER} \
- -x /usr/bin/amuled >${LOG}
-
+ --env HOME="${AMULEHOME}" \
+ --user ${AMULEUSER} \
+ --exec /usr/bin/amuled >${LOG}
+
sleep 2
if ! pgrep -u ${AMULEUSER} amuled > /dev/null; then
eerror "aMule daemon can't be started! Check logfile: ${LOG}"
@@ -37,7 +38,7 @@ start() {
stop() {
ebegin "Stopping aMule daemon -- please wait"
- start-stop-daemon --oknodo --stop --pidfile /var/run/amuled.pid &>/dev/null
+ start-stop-daemon --stop --pidfile /var/run/amuled.pid 2>&1 >/dev/null
eend $?
}
diff --git a/net-p2p/amule/files/amuleweb.initd b/net-p2p/amule/files/amuleweb.initd
index 0484780093a..05e7d9f192b 100644
--- a/net-p2p/amule/files/amuleweb.initd
+++ b/net-p2p/amule/files/amuleweb.initd
@@ -26,12 +26,13 @@ start() {
OPTIONS="-h ${AMULEHOST} -p ${AMULEPORT} -P ${AMULEPWD} -A ${WEBPWD} -t ${TEMPLATE} -q"
ebegin "Starting aMule WebServer"
- env HOME="${AMULEHOME}" start-stop-daemon --start \
- --quiet -b \
+ start-stop-daemon --start \
+ --quiet --background \
--make-pidfile --pidfile /var/run/amuleweb.pid \
- -c ${AMULEUSER} \
- -x /usr/bin/amuleweb -- ${OPTIONS} &>${LOG}
-
+ --env HOME="${AMULEHOME}" \
+ --user ${AMULEUSER} \
+ --exec /usr/bin/amuleweb -- ${OPTIONS} 2>&1 >${LOG}
+
sleep 1
if ! pgrep -u ${AMULEUSER} amuleweb > /dev/null; then
eerror "aMule daemon can't be started! Check logfile: ${LOG}"
@@ -43,7 +44,7 @@ start() {
stop() {
ebegin "Stopping aMule WebServer"
- start-stop-daemon --oknodo --stop --pidfile /var/run/amuleweb.pid &>/dev/null
+ start-stop-daemon --stop --pidfile /var/run/amuleweb.pid 2>&1 >/dev/null
eend $?
}