summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-08-14 23:35:56 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-08-14 23:41:28 +0200
commit1da59e263967d48d77dd96ecdf8a5a5b529e1399 (patch)
tree899cc5da1f24bfbe153e64beb7e2d4edd78351e8
parent0926f31f2448013f8d386130475f417eaeacb2d6 (diff)
downloadgentoo-1da59e263967d48d77dd96ecdf8a5a5b529e1399.tar.gz
gentoo-1da59e263967d48d77dd96ecdf8a5a5b529e1399.tar.xz
www-servers/hiawatha: version bump to 9.14
Gentoo-Bug: 545550
-rw-r--r--www-servers/hiawatha/Manifest1
-rw-r--r--www-servers/hiawatha/hiawatha-9.14.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/www-servers/hiawatha/Manifest b/www-servers/hiawatha/Manifest
index b32d151f130..d351f96f178 100644
--- a/www-servers/hiawatha/Manifest
+++ b/www-servers/hiawatha/Manifest
@@ -1 +1,2 @@
+DIST hiawatha-9.14.tar.gz 891930 SHA256 79c92587cd86a0461d952c99036f5615dacdcaccabe0a9a29359e6044d809bfa SHA512 66ad77c132d34daa5eb597ce67d7b26581c59534e5cf83dd65f78567a9a1798030cd42fef2d612bd1935243db979a2ef1df873f01b0d0a009395ef3da1dca6e6 WHIRLPOOL 8dbeb2c33e9111a27b76f3e5e307872314e85c481a600c39a1e02e7f9e08e1cc0d64f79838dad92a4a5a555cb86334487dd247efb56f0ef9c15a7735da27ddae
DIST hiawatha-9.8.tar.gz 888977 SHA256 6fe9bd408361bc07b47fe6eeaf98d6b644e1cd258b3470da3e70aba510e83b64 SHA512 f55b6065e0dd1dab11ccbbb44e981944aab5b542077fc2b4a03ec8c055be80bedb7b639fe9c52ccf0fc279648b9f4bfc0cbfa018b195b155907810bdfc4ec51a WHIRLPOOL 342c19df23dbe4eef7056f2424d53badede5a8dcf8bb713e7d3892f21e1061ae5e1a0c985f1fc824b10f25eb9fcc9cf0cbf8d384240bf814df4f9dca45dd96f2
diff --git a/www-servers/hiawatha/hiawatha-9.14.ebuild b/www-servers/hiawatha/hiawatha-9.14.ebuild
new file mode 100644
index 00000000000..deb62e55f70
--- /dev/null
+++ b/www-servers/hiawatha/hiawatha-9.14.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# ssl USE flag currently broken, unconditionally enabled
+# rproxy USE flag broken too, unconditionally enabled
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.4"
+
+inherit cmake-utils systemd user
+
+DESCRIPTION="Advanced and secure webserver"
+HOMEPAGE="http://www.hiawatha-webserver.org"
+SRC_URI="http://www.hiawatha-webserver.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cache ipv6 monitor +rewrite tomahawk +xslt"
+
+RDEPEND="
+ xslt? ( dev-libs/libxslt
+ dev-libs/libxml2 )"
+DEPEND="${RDEPEND}"
+PDEPEND="monitor? ( www-apps/hiawatha-monitor )"
+
+# set this in make.conf if you want to use a different user/group
+HIAWATHA_USER=${HIAWATHA_USER:-hiawatha}
+HIAWATHA_GROUP=${HIAWATHA_GROUP:-hiawatha}
+
+pkg_setup() {
+ enewgroup ${HIAWATHA_GROUP}
+ enewuser ${HIAWATHA_USER} -1 -1 /var/www/hiawatha ${HIAWATHA_GROUP}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-9.5-cflags.patch
+
+ grep '#ServerId =' config/hiawatha.conf.in 1>/dev/null || die
+ sed -i \
+ -e "s/#ServerId =.*$/ServerId = ${HIAWATHA_USER}/" \
+ config/hiawatha.conf.in || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DIR:STRING=/etc/hiawatha
+ $(cmake-utils_use_enable cache CACHE)
+ $(cmake-utils_use_enable ipv6 IPV6)
+ $(cmake-utils_use_enable kernel_linux LOADCHECK)
+ $(cmake-utils_use_enable monitor MONITOR)
+ -DENABLE_TLS=YES
+ $(cmake-utils_use_enable tomahawk TOMAHAWK)
+ $(cmake-utils_use_enable rewrite TOOLKIT)
+ $(cmake-utils_use_enable xslt XSLT)
+ -DLOG_DIR:STRING=/var/log/hiawatha
+ -DPID_DIR:STRING=/var/run
+ -DWEBROOT_DIR:STRING=/var/www/hiawatha
+ -DWORK_DIR:STRING=/var/lib/hiawatha
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ rm -rf "${ED%/}"/var/www/hiawatha/*
+
+ newinitd "${FILESDIR}"/hiawatha.initd hiawatha
+ systemd_dounit "${FILESDIR}"/hiawatha.service
+
+ local i
+ for i in /var/{lib,log}/hiawatha ; do
+ keepdir ${i}
+ fowners ${HIAWATHA_USER}:${HIAWATHA_GROUP} ${i}
+ fperms 0750 ${i}
+ done
+
+ keepdir /var/www/hiawatha
+ fowners ${HIAWATHA_USER}:${HIAWATHA_GROUP} /var/www/hiawatha
+}