summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-02-28 22:03:34 -0500
committerTim Harder <radhermit@gentoo.org>2018-02-28 22:06:41 -0500
commit23d4a1821a65f30255d2eb6614522588fcbd469a (patch)
treeee63ee39d8ea3b1860e35696b22cb4e306533c6f
parent0338ca6188e2054e86d805bdab33120739ced86f (diff)
downloadgentoo-23d4a1821a65f30255d2eb6614522588fcbd469a.tar.gz
gentoo-23d4a1821a65f30255d2eb6614522588fcbd469a.tar.xz
app-shells/gentoo-zsh-completions: version bump to 20180228
-rw-r--r--app-shells/gentoo-zsh-completions/Manifest1
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20180228.ebuild28
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild5
3 files changed, 32 insertions, 2 deletions
diff --git a/app-shells/gentoo-zsh-completions/Manifest b/app-shells/gentoo-zsh-completions/Manifest
index 84cf2fb185f..25484f40cb1 100644
--- a/app-shells/gentoo-zsh-completions/Manifest
+++ b/app-shells/gentoo-zsh-completions/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-zsh-completions-20141115.tar.xz 19672 BLAKE2B 13a121686b051355d80f6c36ef6e9fbd3c691b92df439690f0556260ca9ea7529ce1b3a9254811b1d1c4e632e3cfef0da021bf8a34a559dd076f1ed2fc189a8d SHA512 23debde6227574285ba123ad312db535d40813de686ef4c89f1e4cd9acb3c1ab63f5094194a50e6d272ad9ce3fa1ec6ef0bf4cf93424e2ec7adcb4c74572e420
DIST gentoo-zsh-completions-20150103.tar.gz 23759 BLAKE2B 9e48cad8b98df4de9479f06ab394e689f2169c6b52e062806b2051f18b86a6f80b660f472fe48b94bb0aff10095d7fcb9e097aa38710d6f3969cb03cfa4aff5c SHA512 4d87edda071d98672df79e3dbb9565757c0738bc50751d31e5dfefab4f17523387fb2342906ecc0600ce86d888ab4a785756bbb1daf37ca56a3ce1af9e5ae173
+DIST gentoo-zsh-completions-20180228.tar.gz 23246 BLAKE2B a6e4004aa7592cbb097cad55fe9d7286f39bd264d8c463ed22e665ca6a60732b0bc8678a0ac09715e2f34abbadd0e4466d783fdb228ce364bcbe13fb7f097649 SHA512 2b3dcfb910e297eb2f03f4ad9f3749b379ceb60f8b6cbcb7c7d03b7921b79aa21f8d3aa50931c5d4eff52f988a208f1a810c6da7c20720be7a3f2ce4a4564788
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20180228.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20180228.ebuild
new file mode 100644
index 00000000000..391b632254a
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-20180228.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5
+ !<sys-apps/openrc-0.35"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
index cf137815c47..fda2e863152 100644
--- a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -17,7 +17,8 @@ HOMEPAGE="https://github.com/gentoo/gentoo-zsh-completions"
LICENSE="ZSH"
SLOT="0"
-RDEPEND=">=app-shells/zsh-4.3.5"
+RDEPEND=">=app-shells/zsh-4.3.5
+ !<sys-apps/openrc-0.35"
src_install() {
insinto /usr/share/zsh/site-functions