summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-06 10:00:27 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-06 14:38:42 +0100
commit26241b380c5e432889fa0c93e3914f141abf6187 (patch)
tree85146415c7ca4c507eb6762d902156d963ea64a2
parent9ef553f2eb3832035c7408e00b2186bb732b5a20 (diff)
downloadgentoo-26241b380c5e432889fa0c93e3914f141abf6187.tar.gz
gentoo-26241b380c5e432889fa0c93e3914f141abf6187.tar.xz
dev-python/python-gnupg: Clean old up
-rw-r--r--dev-python/python-gnupg/Manifest1
-rw-r--r--dev-python/python-gnupg/files/python-gnupg-0.3.6-skip-search-keys-tests.patch20
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild26
3 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/python-gnupg/Manifest b/dev-python/python-gnupg/Manifest
index 62479a86e22..c9c71e40830 100644
--- a/dev-python/python-gnupg/Manifest
+++ b/dev-python/python-gnupg/Manifest
@@ -1,2 +1 @@
-DIST python-gnupg-0.3.8.tar.gz 38993 BLAKE2B ec3b4c810fa57a927744f7e49bd5680e4fa50eab2839d82ba5721bed405d84c3a820d40966b4b139c57a0427de543ea845ec5404a68434334695a695e052f712 SHA512 128ba1f89e8baf0d1ae53153d7cbe73bfc99617a1aadfd9a02e2e2e2c5f0bb9c7482023bf54f32989e92cc14a9eb32325e4c358c63bce48a70a78d068103ed4f
DIST python-gnupg-0.4.0.tar.gz 43987 BLAKE2B 59e72f894c5d554ba2a7c348ad3625500798ad6ac18332a3bb668b42559f52b58e3cd0f8b79ef1a99f37e796b48169d0bf36414e938e9039784cede4303cbb03 SHA512 f486ec97aee01cf46d055421211ff5704093a382155043b7ced6f809dc15d7669d5869038a1b26c5f1831076d85c929d781bc22e35ab293a14bc6e2f5f27fa32
diff --git a/dev-python/python-gnupg/files/python-gnupg-0.3.6-skip-search-keys-tests.patch b/dev-python/python-gnupg/files/python-gnupg-0.3.6-skip-search-keys-tests.patch
deleted file mode 100644
index 66512ab0816..00000000000
--- a/dev-python/python-gnupg/files/python-gnupg-0.3.6-skip-search-keys-tests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- python-gnupg-0.3.6/gnupg.py
-+++ python-gnupg-0.3.6/gnupg.py
-@@ -1078,6 +1078,7 @@
- def search_keys(self, query, keyserver='pgp.mit.edu'):
- """ search keyserver by query (using --search-keys option)
-
-+ # doctest: +SKIP
- >>> import shutil
- >>> shutil.rmtree('keys')
- >>> gpg = GPG(gnupghome='keys')
---- python-gnupg-0.3.6/test_gnupg.py
-+++ python-gnupg-0.3.6/test_gnupg.py
-@@ -493,6 +493,7 @@
- os.remove(fn)
- logger.debug("test_file_encryption_and_decryption ends")
-
-+ @unittest.skip("requires network access")
- def test_search_keys(self):
- "Test that searching for keys works"
- r = self.gpg.search_keys('<vinay_sajip@hotmail.com>')
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild
deleted file mode 100644
index f10324007a6..00000000000
--- a/dev-python/python-gnupg/python-gnupg-0.3.8-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for GNU Privacy Guard"
-HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-
-RDEPEND="app-crypt/gnupg"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.3.6-skip-search-keys-tests.patch )
-
-python_test() {
- # Note; 1 test fails under pypy only
- "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
-}