summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-10-04 12:11:42 +0200
committerSven Wegener <swegener@gentoo.org>2017-10-05 21:35:44 +0000
commit2b41864cd150b5dd1c5c45478c287ec87676f6e3 (patch)
treed26c595c3577d483b337b07537e245e75d53328f
parent84db9af53abcfc1c79938330d0a80b20bbb33f74 (diff)
downloadgentoo-2b41864cd150b5dd1c5c45478c287ec87676f6e3.tar.gz
gentoo-2b41864cd150b5dd1c5c45478c287ec87676f6e3.tar.xz
net-nntp/nzbget: improve init script to use a pid file, add depend
It seems that the older behaviour did not work with recent openrc versions. The process could not be found when running the stop command. We don't need to override LockFile in the configuration file any more since we set it when we start the daemon. Package-Manager: Portage-2.3.8, Repoman-2.3.3 [swegener: separate init script revision]
-rw-r--r--net-nntp/nzbget/files/nzbget.initd-r128
-rw-r--r--net-nntp/nzbget/nzbget-20.0_pre2108-r1.ebuild (renamed from net-nntp/nzbget/nzbget-20.0_pre2108.ebuild)3
2 files changed, 29 insertions, 2 deletions
diff --git a/net-nntp/nzbget/files/nzbget.initd-r1 b/net-nntp/nzbget/files/nzbget.initd-r1
new file mode 100644
index 00000000000..2a9fae6c32b
--- /dev/null
+++ b/net-nntp/nzbget/files/nzbget.initd-r1
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+extra_started_commands="reload"
+
+description="A command-line based binary newsgrabber supporting .nzb files"
+pidfile=/run/nzbget/nzbget.pid
+command=/usr/bin/nzbget
+command_args="--configfile \"${NZBGET_CONFIGFILE}\" \
+ --daemon --option LockFile=${pidfile} \
+ ${NZBGET_OPTS}"
+start_stop_daemon_args="--user \"${NZBGET_USER}\" \
+ --group \"${NZBGET_GROUP}\""
+
+depend() {
+ need localmount net
+}
+
+start_pre() {
+ checkpath -d -m 0755 -o "${NZBGET_USER}":"${NZBGET_GROUP}" /run/nzbget
+}
+
+reload() {
+ ebegin "Reloading ${RC_SVCNAME}"
+ ${command} --configfile "${NZBGET_CONFIGFILE}" --reload >/dev/null
+ eend $?
+}
diff --git a/net-nntp/nzbget/nzbget-20.0_pre2108.ebuild b/net-nntp/nzbget/nzbget-20.0_pre2108-r1.ebuild
index c6d86f04383..3e119a13d9e 100644
--- a/net-nntp/nzbget/nzbget-20.0_pre2108.ebuild
+++ b/net-nntp/nzbget/nzbget-20.0_pre2108-r1.ebuild
@@ -58,7 +58,6 @@ src_prepare() {
sed \
-e 's:^MainDir=.*:MainDir=/var/lib/nzbget:' \
- -e 's:^LockFile=.*:LockFile=/run/nzbget/nzbget.pid:' \
-e 's:^LogFile=.*:LogFile=/var/log/nzbget/nzbget.log:' \
-e 's:^WebDir=.*:WebDir=/usr/share/nzbget/webui:' \
-e 's:^ConfigTemplate=.*:ConfigTemplate=/usr/share/nzbget/nzbget.conf:' \
@@ -91,7 +90,7 @@ src_install() {
keepdir /var/lib/nzbget/{dst,nzb,queue,tmp}
keepdir /var/log/nzbget
- newinitd "${FILESDIR}"/nzbget.initd nzbget
+ newinitd "${FILESDIR}"/nzbget.initd-r1 nzbget
newconfd "${FILESDIR}"/nzbget.confd nzbget
}