summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-23 23:20:48 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-23 23:51:40 -0600
commit2eaab98bf6382911a816628cbd404f73388de825 (patch)
treea9909af2c587908c25ac8d630b59c7d2dd9e72e1
parentf0d7b567b8702ec92e3db3dcf691694407ed02a4 (diff)
downloadgentoo-2eaab98bf6382911a816628cbd404f73388de825.tar.gz
gentoo-2eaab98bf6382911a816628cbd404f73388de825.tar.xz
dev-python/os-xenapi: 0.3.1 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/os-xenapi/Manifest1
-rw-r--r--dev-python/os-xenapi/os-xenapi-0.3.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/os-xenapi/Manifest b/dev-python/os-xenapi/Manifest
index 9d9f923643f..5105d38eb84 100644
--- a/dev-python/os-xenapi/Manifest
+++ b/dev-python/os-xenapi/Manifest
@@ -1 +1,2 @@
DIST os-xenapi-0.2.0.tar.gz 73753 BLAKE2B dbb42c1fe15a55e39622876293d7797801ee4e67d152957e32e88a1d1a4503a2d70ab144216924c7d45935bbc79109a76535cc0b121df63e82468a37cb353cfc SHA512 6eb7a8b8137c6c28cf07af51ddfed9aa08ad5af3cafd48ed72d9fa909d0dd2416e17eed8a587fc5cffac55704652e24ef8e759f60806b569f2765a5fff58884f
+DIST os-xenapi-0.3.1.tar.gz 121953 BLAKE2B 4c2091fe0d7610dea7e973a6db68b0edea62d7323d09b0e3cc0c3a43b9a5a4b4509e29ee9e48755958f8d99dd5db2bb6ea13a3425c0156388e19ff986f86fa24 SHA512 24c1fa9e7b3e37b7847d7f82a533d9c92e7b551bd69681a985950d92ba22974a495e10ab7acf0f8f6a9a6fc9bf4c71820f413f948684a5b17d010dd076749cf4
diff --git a/dev-python/os-xenapi/os-xenapi-0.3.1.ebuild b/dev-python/os-xenapi/os-xenapi-0.3.1.ebuild
new file mode 100644
index 00000000000..277791e4eaa
--- /dev/null
+++ b/dev-python/os-xenapi/os-xenapi-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="XenAPI library for OpenStack projects"
+HOMEPAGE="https://github.com/openstack/os-xenapi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.28.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}