summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-11-06 10:39:23 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-11-06 10:39:45 -0600
commit3220ea651e19676698a21e5f81cb0901f791a963 (patch)
treea86666c63565b42d6fc8a224a5960296f86aec1c
parentaa434f40ed88d685aad1f1e66e308503e22b44b0 (diff)
downloadgentoo-3220ea651e19676698a21e5f81cb0901f791a963.tar.gz
gentoo-3220ea651e19676698a21e5f81cb0901f791a963.tar.xz
sys-boot/plymouth: 0.9.4 bump with cleanup
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--sys-boot/plymouth/Manifest2
-rw-r--r--sys-boot/plymouth/plymouth-0.9.2-r1.ebuild100
-rw-r--r--sys-boot/plymouth/plymouth-0.9.4.ebuild (renamed from sys-boot/plymouth/plymouth-0.9.3.ebuild)25
-rw-r--r--sys-boot/plymouth/plymouth-9999.ebuild10
4 files changed, 22 insertions, 115 deletions
diff --git a/sys-boot/plymouth/Manifest b/sys-boot/plymouth/Manifest
index b0737363982..9e889ee2efe 100644
--- a/sys-boot/plymouth/Manifest
+++ b/sys-boot/plymouth/Manifest
@@ -1,3 +1,3 @@
DIST gentoo-logo.png 14501 BLAKE2B e7236c16b96a2d35a6f062b89bc0a6c6fc696a803b7da734ff9ae255fcd65e549d9bc3d510c283e235a770f42edcbdffc1d5cc4c2fcdec9cc931eb0acf504859 SHA512 059a555931b6d2a910bcd887f5ea0cc17c6edf2d2d45c03a1fec1bdda0138ba6bca6bdf90a65c6520a3f8f1b51ecf6f7956098f45ed6c1276f29c835e729163c
-DIST plymouth-0.9.2.tar.bz2 1231336 BLAKE2B 2e565b0bb23dbab19bc164756165ca85793df3fe0e2df0c9aa2aa7e827f19f7b531951f2b7a302368e8b86829555754cc8cb67606291a80242b0a23a023643c7 SHA512 89356eb8326504fbf3155de262ce15de0847f0a0e6d157d873cf1dea9af464a6cb9e11d7143ee9a595b217a2487060b5835eba5ac142c3cd6d66689deb272e60
DIST plymouth-0.9.3.tar.xz 1102724 BLAKE2B 7ee17cc785e6197cc9488afe6ceae27541992872813a9f937211930f653207d77c1a331cb093156af5ec9502a04cf1f9e4123c42e07931eaf270fefedcc03700 SHA512 d7b9ba97485cdac7ad6bcaf5a7f1a9c84ece54b8d46d5efce4170294c0aa6571656d7d9957b53aed9c1e51d4d525714f54b7dbb08d8ec0b196a1a4419fd186ed
+DIST plymouth-0.9.4.tar.xz 1103496 BLAKE2B abad2cefb89e9d17b77113396d7203090544759b3dd7f73f67153d9f126db28e5366d36aa11e2335566bf4046bebd50d8d9dd47c75634446fb3a0314cd458925 SHA512 83eb2de7e6d0980e9f7fa4e0b0f20c46a8238051d84bc38dbbb5dfa438e41c1a39846dcd652374256d9f1fe79967b154a3576cd9c433ef816b6c962be2d31e93
diff --git a/sys-boot/plymouth/plymouth-0.9.2-r1.ebuild b/sys-boot/plymouth/plymouth-0.9.2-r1.ebuild
deleted file mode 100644
index e0c922e5449..00000000000
--- a/sys-boot/plymouth/plymouth-0.9.2-r1.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-SRC_URI="
- https://dev.gentoo.org/~aidecoe/distfiles/sys-boot/plymouth/gentoo-logo.png"
-
-AUTOTOOLS_AUTORECONF="1"
-if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="https://anongit.freedesktop.org/git/plymouth"
- inherit git-r3
-else
- SRC_URI="${SRC_URI} https://www.freedesktop.org/software/plymouth/releases/${P}.tar.bz2"
-fi
-
-inherit autotools-utils readme.gentoo systemd toolchain-funcs
-
-DESCRIPTION="Graphical boot animation (splash) and logger"
-HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
-
-LICENSE="GPL-2"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
-IUSE="debug gdm +gtk +libkms +pango static-libs"
-
-CDEPEND="
- >=media-libs/libpng-1.2.16:=
- gtk? (
- dev-libs/glib:2
- >=x11-libs/gtk+-3.14:3
- x11-libs/cairo )
- libkms? ( x11-libs/libdrm[libkms] )
- pango? ( >=x11-libs/pango-1.21 )
-"
-DEPEND="${CDEPEND}
- virtual/pkgconfig
-"
-# Block due bug #383067
-RDEPEND="${CDEPEND}
- virtual/udev
- !<sys-kernel/dracut-0.37-r3
-"
-
-DOC_CONTENTS="
- Follow the following instructions to set up Plymouth:\n
- https://wiki.gentoo.org/wiki/Plymouth#Configuration
-"
-
-PATCHES=(
- "${FILESDIR}/0.9.2-systemdsystemunitdir.patch"
-)
-
-src_prepare() {
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=(
- --with-system-root-install=no
- --localstatedir=/var
- --without-rhgb-compat-link
- --enable-systemd-integration
- "$(systemd_with_unitdir)"
- $(use_enable debug tracing)
- $(use_enable gtk gtk)
- $(use_enable libkms drm)
- $(use_enable pango)
- $(use_enable gdm gdm-transition)
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- insinto /usr/share/plymouth
- newins "${DISTDIR}"/gentoo-logo.png bizcom.png
-
- # Install compatibility symlinks as some rdeps hardcode the paths
- dosym /usr/bin/plymouth /bin/plymouth
- dosym /usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
- dosym /usr/sbin/plymouthd /sbin/plymouthd
-
- readme.gentoo_create_doc
-
- # looks like make install create /var/run/plymouth
- # this is not needed for systemd, same should hold for openrc
- # so remove
- rm -rf "${D}"/var/run
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
- if ! has_version "sys-kernel/dracut" && ! has_version "sys-kernel/genkernel-next[plymouth]"; then
- ewarn "If you want initramfs builder with plymouth support, please emerge"
- ewarn "sys-kernel/dracut or sys-kernel/genkernel-next[plymouth]."
- fi
-}
diff --git a/sys-boot/plymouth/plymouth-0.9.3.ebuild b/sys-boot/plymouth/plymouth-0.9.4.ebuild
index 75326f75a37..f10bd902367 100644
--- a/sys-boot/plymouth/plymouth-0.9.3.ebuild
+++ b/sys-boot/plymouth/plymouth-0.9.4.ebuild
@@ -1,15 +1,17 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+inherit flag-o-matic
SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
if [[ ${PV} == 9999 ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/plymouth"
inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/plymouth"
else
SRC_URI="${SRC_URI} https://www.freedesktop.org/software/plymouth/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
fi
inherit autotools readme.gentoo-r1 systemd toolchain-funcs
@@ -19,8 +21,6 @@ HOMEPAGE="https://cgit.freedesktop.org/plymouth/"
LICENSE="GPL-2"
SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug gdm +gtk +libkms +pango static-libs"
CDEPEND="
@@ -28,11 +28,15 @@ CDEPEND="
gtk? (
dev-libs/glib:2
>=x11-libs/gtk+-3.14:3
- x11-libs/cairo )
+ x11-libs/cairo
+ )
libkms? ( x11-libs/libdrm[libkms] )
pango? ( >=x11-libs/pango-1.21 )
"
DEPEND="${CDEPEND}
+ elibc_musl? ( sys-libs/rpmatch-standalone )
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
virtual/pkgconfig
"
# Block due bug #383067
@@ -47,9 +51,11 @@ DOC_CONTENTS="
"
PATCHES=(
+ "${FILESDIR}"/0.9.3-glibc-sysmacros.patch
)
src_prepare() {
+ use elibc_musl && append-ldflags -lrpmatch
default
eautoreconf
}
@@ -59,6 +65,7 @@ src_configure() {
--with-system-root-install=no
--localstatedir=/var
--without-rhgb-compat-link
+ --enable-documentation
--enable-systemd-integration
--with-systemdunitdir="$(systemd_get_systemunitdir)"
$(use_enable !static-libs shared)
@@ -79,9 +86,9 @@ src_install() {
newins "${DISTDIR}"/gentoo-logo.png bizcom.png
# Install compatibility symlinks as some rdeps hardcode the paths
- dosym /usr/bin/plymouth /bin/plymouth
- dosym /usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
- dosym /usr/sbin/plymouthd /sbin/plymouthd
+ dosym ../usr/bin/plymouth /bin/plymouth
+ dosym ..../usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
+ dosym ../usr/sbin/plymouthd /sbin/plymouthd
readme.gentoo_create_doc
diff --git a/sys-boot/plymouth/plymouth-9999.ebuild b/sys-boot/plymouth/plymouth-9999.ebuild
index 5ffedf306a9..f10bd902367 100644
--- a/sys-boot/plymouth/plymouth-9999.ebuild
+++ b/sys-boot/plymouth/plymouth-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic
SRC_URI="https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/gentoo-logo.png"
@@ -86,9 +86,9 @@ src_install() {
newins "${DISTDIR}"/gentoo-logo.png bizcom.png
# Install compatibility symlinks as some rdeps hardcode the paths
- dosym /usr/bin/plymouth /bin/plymouth
- dosym /usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
- dosym /usr/sbin/plymouthd /sbin/plymouthd
+ dosym ../usr/bin/plymouth /bin/plymouth
+ dosym ..../usr/sbin/plymouth-set-default-theme /sbin/plymouth-set-default-theme
+ dosym ../usr/sbin/plymouthd /sbin/plymouthd
readme.gentoo_create_doc