summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-09-09 23:19:39 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2015-09-09 23:22:29 +0200
commit4469f6ce771cb10ab430fa5741a519ef63153594 (patch)
tree01a7a730e5cfbb7f078e7e26472942c6866e51c4
parentc2d919c7afccc60201b98f5f651ec77babf3dfe6 (diff)
downloadgentoo-4469f6ce771cb10ab430fa5741a519ef63153594.tar.gz
gentoo-4469f6ce771cb10ab430fa5741a519ef63153594.tar.xz
x11-misc/sddm: sync 0.11.0 ebuild with 0.12.0
Remove no longer needed r2. Remove upower USE. Gentoo-Bug: 559114 Package-Manager: portage-2.2.20.1
-rw-r--r--x11-misc/sddm/files/sddm-0.10.0-consolekit.patch13
-rw-r--r--x11-misc/sddm/files/sddm-0.11.0-consolekit2.patch91
-rw-r--r--x11-misc/sddm/files/sddm-0.11.0-upower.patch11
-rw-r--r--x11-misc/sddm/sddm-0.11.0-r2.ebuild76
-rw-r--r--x11-misc/sddm/sddm-0.11.0-r3.ebuild (renamed from x11-misc/sddm/sddm-0.11.0-r1.ebuild)17
5 files changed, 8 insertions, 200 deletions
diff --git a/x11-misc/sddm/files/sddm-0.10.0-consolekit.patch b/x11-misc/sddm/files/sddm-0.10.0-consolekit.patch
deleted file mode 100644
index acdfdc1a43e..00000000000
--- a/x11-misc/sddm/files/sddm-0.10.0-consolekit.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/data/scripts/Xsession b/data/scripts/Xsession
-index a5d270d..4b48524 100755
---- a/data/scripts/Xsession
-+++ b/data/scripts/Xsession
-@@ -74,7 +74,7 @@ case $session in
- exec xterm -geometry 80x24-0-0
- ;;
- *)
-- eval exec "$session"
-+ eval exec ck-launch-session "$session"
- ;;
- esac
- exec xmessage -center -buttons OK:0 -default OK "Sorry, cannot execute $session. Check $DESKTOP_SESSION.desktop."
diff --git a/x11-misc/sddm/files/sddm-0.11.0-consolekit2.patch b/x11-misc/sddm/files/sddm-0.11.0-consolekit2.patch
deleted file mode 100644
index 7f6f3f7f811..00000000000
--- a/x11-misc/sddm/files/sddm-0.11.0-consolekit2.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From 7a8024639ee3ae7e128a9dc3efce90a07b4d316c Mon Sep 17 00:00:00 2001
-From: Eric Koegel <eric.koegel@gmail.com>
-Date: Mon, 6 Jul 2015 11:16:38 +0300
-Subject: [PATCH] ConsoleKit2 support for system actions
-
-This adds support for calling ConsoleKit2's DBUS API for shutdown,
-reboot, suspend, and hibernate. It does so by using the exact same
-interface as login1, making it a shared seat manager backend.
----
- INSTALL | 4 ++--
- src/daemon/PowerManager.cpp | 26 +++++++++++++++++---------
- 2 files changed, 19 insertions(+), 11 deletions(-)
-
-diff --git a/INSTALL b/INSTALL
-index 77b6a8b..5d16710 100644
---- a/INSTALL
-+++ b/INSTALL
-@@ -30,8 +30,8 @@ its home set to `/var/lib/sddm` by default.
- SDDM depends on PAM for authorization and XCB to communicate with the X server.
- Apart from other things, it also depends on Qt for the user interface and event
- loop management.
--SDDM can optionally make use of logind (the systemd login manager API) or
--upower to enable support for suspend, hibernate etc.
-+SDDM can optionally make use of logind (the systemd login manager API), or
-+ConsoleKit2, or upower to enable support for suspend, hibernate etc.
- In order to build the man pages, you will need `rst2man` installed. It is
- provided by the python `docutils` package
-
-diff --git a/src/daemon/PowerManager.cpp b/src/daemon/PowerManager.cpp
-index 3a4d25d..6329032 100644
---- a/src/daemon/PowerManager.cpp
-+++ b/src/daemon/PowerManager.cpp
-@@ -59,8 +59,8 @@ namespace SDDM {
-
- class UPowerBackend : public PowerManagerBackend {
- public:
-- UPowerBackend() {
-- m_interface = new QDBusInterface(UPOWER_SERVICE, UPOWER_PATH, UPOWER_OBJECT, QDBusConnection::systemBus());
-+ UPowerBackend(const QString & service, const QString & path, const QString & interface) {
-+ m_interface = new QDBusInterface(service, path, interface, QDBusConnection::systemBus());
- }
-
- ~UPowerBackend() {
-@@ -110,20 +110,24 @@ namespace SDDM {
- };
-
- /**********************************************/
-- /* LOGIN1 BACKEND */
-+ /* LOGIN1 && ConsoleKit2 BACKEND */
- /**********************************************/
-
- #define LOGIN1_SERVICE QStringLiteral("org.freedesktop.login1")
- #define LOGIN1_PATH QStringLiteral("/org/freedesktop/login1")
- #define LOGIN1_OBJECT QStringLiteral("org.freedesktop.login1.Manager")
-
-- class Login1Backend : public PowerManagerBackend {
-+#define CK2_SERVICE QStringLiteral("org.freedesktop.ConsoleKit")
-+#define CK2_PATH QStringLiteral("/org/freedesktop/ConsoleKit/Manager")
-+#define CK2_OBJECT QStringLiteral("org.freedesktop.ConsoleKit.Manager")
-+
-+ class SeatManagerBackend : public PowerManagerBackend {
- public:
-- Login1Backend() {
-- m_interface = new QDBusInterface(LOGIN1_SERVICE, LOGIN1_PATH, LOGIN1_OBJECT, QDBusConnection::systemBus());
-+ SeatManagerBackend(const QString & service, const QString & path, const QString & interface) {
-+ m_interface = new QDBusInterface(service, path, interface, QDBusConnection::systemBus());
- }
-
-- ~Login1Backend() {
-+ ~SeatManagerBackend() {
- delete m_interface;
- }
-
-@@ -194,11 +198,15 @@ namespace SDDM {
-
- // check if login1 interface exists
- if (interface->isServiceRegistered(LOGIN1_SERVICE))
-- m_backends << new Login1Backend();
-+ m_backends << new SeatManagerBackend(LOGIN1_SERVICE, LOGIN1_PATH, LOGIN1_OBJECT);
-+
-+ // check if ConsoleKit2 interface exists
-+ if (interface->isServiceRegistered(CK2_SERVICE))
-+ m_backends << new SeatManagerBackend(CK2_SERVICE, CK2_PATH, CK2_OBJECT);
-
- // check if upower interface exists
- if (interface->isServiceRegistered(UPOWER_SERVICE))
-- m_backends << new UPowerBackend();
-+ m_backends << new UPowerBackend(UPOWER_SERVICE, UPOWER_PATH, UPOWER_OBJECT);
- }
-
- PowerManager::~PowerManager() {
diff --git a/x11-misc/sddm/files/sddm-0.11.0-upower.patch b/x11-misc/sddm/files/sddm-0.11.0-upower.patch
deleted file mode 100644
index 387f106c29b..00000000000
--- a/x11-misc/sddm/files/sddm-0.11.0-upower.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/daemon/PowerManager.cpp 2015-08-17 00:52:12.786176023 +0200
-+++ b/src/daemon/PowerManager.cpp 2015-08-17 00:53:30.259207476 +0200
-@@ -209,7 +209,7 @@
- #endif // HAVE_CONSOLEKIT2
-
- // check if upower interface exists
-- if (interface->isServiceRegistered(UPOWER_SERVICE))
-+// if (interface->isServiceRegistered(UPOWER_SERVICE))
- m_backends << new UPowerBackend(UPOWER_SERVICE, UPOWER_PATH, UPOWER_OBJECT);
- }
-
diff --git a/x11-misc/sddm/sddm-0.11.0-r2.ebuild b/x11-misc/sddm/sddm-0.11.0-r2.ebuild
deleted file mode 100644
index 5057c94fd70..00000000000
--- a/x11-misc/sddm/sddm-0.11.0-r2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils toolchain-funcs user
-
-DESCRIPTION="Simple Desktop Display Manager"
-HOMEPAGE="https://github.com/sddm/sddm"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~arm ~x86"
-
-LICENSE="GPL-2+ MIT CC-BY-3.0 public-domain"
-SLOT="0"
-IUSE="consolekit systemd +upower"
-REQUIRED_USE="?? ( upower systemd )"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtdeclarative:5
- dev-qt/linguist-tools:5
- dev-qt/qttest:5
- sys-libs/pam
- >=x11-base/xorg-server-1.15.1
- x11-libs/libxcb[xkb(-)]
- consolekit? ( >=sys-auth/consolekit-0.9.4 )
- systemd? ( sys-apps/systemd:= )
- upower? ( || ( sys-power/upower sys-power/upower-pm-utils ) )"
-DEPEND="${RDEPEND}
- >=sys-devel/gcc-4.7.0
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${P}-consolekit2.patch"
- "${FILESDIR}/${P}-dbus-config.patch"
-)
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary && $(tc-getCC) == *gcc* ]]; then
- if [[ $(gcc-major-version) -lt 4 || $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 7 ]] ; then
- die 'The active compiler needs to be gcc 4.7 (or newer)'
- fi
- fi
-}
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 /var/lib/sddm ${PN}
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- use consolekit && epatch "${FILESDIR}/${PN}-0.10.0-consolekit.patch"
- use upower && epatch "${FILESDIR}/${P}-upower.patch"
-
- # respect user's cflags
- sed -e 's|-Wall -march=native||' \
- -e 's|-O2||' \
- -i CMakeLists.txt || die 'sed failed'
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_no systemd SYSTEMD)
- -DDBUS_CONFIG_FILENAME:STRING="org.freedesktop.sddm.conf"
- )
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- ewarn "Add the sddm user manually to the video group"
- ewarn "if you experience flickering or other rendering issues of sddm-greeter"
- ewarn "see https://github.com/gentoo/qt/pull/52"
-}
diff --git a/x11-misc/sddm/sddm-0.11.0-r1.ebuild b/x11-misc/sddm/sddm-0.11.0-r3.ebuild
index 2cab5ed1980..5c7c96445b9 100644
--- a/x11-misc/sddm/sddm-0.11.0-r1.ebuild
+++ b/x11-misc/sddm/sddm-0.11.0-r3.ebuild
@@ -12,8 +12,7 @@ KEYWORDS="~amd64 ~arm ~x86"
LICENSE="GPL-2+ MIT CC-BY-3.0 public-domain"
SLOT="0"
-IUSE="consolekit systemd +upower"
-REQUIRED_USE="?? ( upower systemd )"
+IUSE="consolekit systemd"
RDEPEND="sys-libs/pam
>=x11-base/xorg-server-1.15.1
@@ -24,21 +23,21 @@ RDEPEND="sys-libs/pam
dev-qt/linguist-tools:5
dev-qt/qttest:5
systemd? ( sys-apps/systemd:= )
- upower? ( || ( sys-power/upower sys-power/upower-pm-utils ) )"
+ !systemd? ( || ( sys-power/upower sys-power/upower-pm-utils ) )"
DEPEND="${RDEPEND}
- >=sys-devel/gcc-4.7.0
virtual/pkgconfig"
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- [[ $(gcc-version) < 4.7 ]] && \
+ if [[ ${MERGE_TYPE} != binary && $(tc-getCC) == *gcc* ]]; then
+ if [[ $(gcc-major-version) -lt 4 || $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 7 ]] ; then
die 'The active compiler needs to be gcc 4.7 (or newer)'
+ fi
fi
}
src_prepare() {
use consolekit && epatch "${FILESDIR}/${P}-consolekit.patch"
- use upower && epatch "${FILESDIR}/${PN}-0.10.0-upower.patch"
+ use !systemd && epatch "${FILESDIR}/${PN}-0.10.0-upower.patch"
# fix bug 552318
epatch "${FILESDIR}/${P}-dbus-config.patch"
@@ -68,7 +67,7 @@ pkg_postinst() {
ewarn "see https://github.com/gentoo/qt/pull/52"
}
-pkg_setup() {
+pkg_postinst() {
enewgroup ${PN}
- enewuser ${PN} -1 -1 /var/lib/sddm ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN} video
}