summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-07 05:08:45 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-07 05:08:45 -0400
commit4476e9893735ee89bc074d6fa177233e014d4051 (patch)
tree6a4479be2fdcbba223f623e61a159c6b49076ce1
parent77a793e22a8c1b873aebc835bc387aa684e4bcde (diff)
downloadgentoo-4476e9893735ee89bc074d6fa177233e014d4051.tar.gz
gentoo-4476e9893735ee89bc074d6fa177233e014d4051.tar.xz
media-sound/csound: always define csound_ac interfaces for cmake
-rw-r--r--media-sound/csound/csound-6.07.0.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/media-sound/csound/csound-6.07.0.ebuild b/media-sound/csound/csound-6.07.0.ebuild
index 6ea7a0b1f32..3a9ef3230a5 100644
--- a/media-sound/csound/csound-6.07.0.ebuild
+++ b/media-sound/csound/csound-6.07.0.ebuild
@@ -116,13 +116,6 @@ src_prepare() {
src_configure() {
local myconf=()
- if use csoundac ; then
- myconf+=(
- -DBUILD_CSOUND_AC_PYTHON_INTERFACE=$(usex python)
- -DBUILD_CSOUND_AC_LUA_INTERFACE=$(usex lua)
- )
- fi
-
use python && myconf+=( "-DPYTHON_MODULE_INSTALL_DIR=$(python_get_sitedir)" )
[[ $(get_libdir) == "lib64" ]] && myconf+=( -DUSE_LIB64=ON )
@@ -132,6 +125,8 @@ src_configure() {
-DBUILD_CSBEATS=$(usex beats)
-DBUILD_CHUA_OPCODES=$(usex chua)
-DBUILD_CSOUND_AC=$(usex csoundac)
+ -DBUILD_CSOUND_AC_LUA_INTERFACE=$(usex csoundac $(usex lua))
+ -DBUILD_CSOUND_AC_PYTHON_INTERFACE=$(usex csoundac $(usex python))
-DBUILD_CXX_INTERFACE=$(usex cxx)
-DUSE_CURL=$(usex curl)
-DNEW_PARSER_DEBUG=$(usex debug)